The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issues with Apache

Discussion in 'EasyApache' started by TNiSolutions, Oct 17, 2011.

  1. TNiSolutions

    TNiSolutions Well-Known Member

    Joined:
    May 30, 2011
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    I am trying to rebuild apache with mod security and mod ssl enabled. I tried running a upcp to see if that fixed it with no luck.

    When I run /scripts/easyapache, I get the following:
    Code:
    root@server4 [~]# /scripts/easyapache 
    !! Critical Warning (VZ): You are only only allowed to use 429 Megabytes of ram! 512 Megabytes is recommended. !!
    !! Pre allocation testing was successfully able to allocate 90MB !!
    !! 
    Ouput from '/bin/sh -c "ulimit -a"': 
    core file size          (blocks, -c) 0
    data seg size           (kbytes, -d) unlimited
    scheduling priority             (-e) 0
    file size               (blocks, -f) unlimited
    pending signals                 (-i) 139264
    max locked memory       (kbytes, -l) 32
    max memory size         (kbytes, -m) 524288
    open files                      (-n) 1024
    pipe size            (512 bytes, -p) 8
    POSIX message queues     (bytes, -q) 819200
    real-time priority              (-r) 0
    stack size              (kbytes, -s) 10240
    cpu time               (seconds, -t) unlimited
    max user processes              (-u) 139264
    virtual memory          (kbytes, -v) 524288
    file locks                      (-x) unlimited
    !!
    Can't locate Curses/UI.pm in @INC (@INC contains: /usr/local/cpanel/scripts/../lib /usr/local/cpanel /var/cpanel/easy/apache/custom_opt_mods /var/cpanel/perl/easy /scripts /usr/local/lib/perl5/5.8.8/x86_64-linux /usr/local/lib/perl5/5.8.8 /usr/local/lib/perl5/site_perl/5.8.8/x86_64-linux /usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl .) at /var/cpanel/perl/easy/Cpanel/Easy/Apache/UI/CLI/Config.pm line 5.
    BEGIN failed--compilation aborted at /var/cpanel/perl/easy/Cpanel/Easy/Apache/UI/CLI/Config.pm line 5.
    Compilation failed in require at /var/cpanel/perl/easy/Cpanel/Easy/Apache/UI/CLI.pm line 406.
    root@server4 [~]# 
     
  2. ModServ

    ModServ Well-Known Member

    Joined:
    Oct 17, 2006
    Messages:
    332
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
    Maybe a memory issue:

    Or you could try something like that:

    PHP:
    /scripts/checkperlmodules
    But I guess it's just a memory issue.
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
Loading...

Share This Page