The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issues with backups transfering to remote FTP location

Discussion in 'Data Protection' started by Cloudpockets, May 31, 2016.

  1. Cloudpockets

    Cloudpockets Registered

    May 25, 2016
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    I have setup automated backups for all the accounts on our WHM server using the Backup Configuration module.

    The problem I'm having is that the transfer process to a remote FTP site is mostly failing, or outright failing. When I check my remote FTP site, I either have only a handful of backup accounts, no backup accounts, or a bunch of empty backup accounts.

    I've checked the cPanel backup log and it creates all the account backup packages and puts them in the default backup folder on the WHM server no problems.

    But when checking the transporter log, between 90% to 100% of the accounts fail to transfer to the remote FTP site. I'm getting this error message in the log:

    [2016-05-29 05:58:25 +0400] info [cpbackup_transporter] cpbackup_transporter - Checking queue for tasks
    [2016-05-29 05:58:25 +0400] info [cpbackup_transporter] cpbackup_transporter - Processing next task
    [2016-05-29 05:58:25 +0400] info [cpbackup_transporter] Starting a "copy" operation on the "Offsite FTP" destination ID "ecIHBx8NTaV1NK3q0dv4DvUz".
    [2016-05-29 05:58:25 +0400] info [cpbackup_transporter] Base path for destination is /rose
    [2016-05-29 05:58:26 +0400] info [cpbackup_transporter] Upload attempt #1 starting for /backup/weekly/2016-05-29/accounts/inxsnet.tar.gz to /rose/weekly/2016-05-29/inxsnet.tar.gz for destination:  Offsite FTP
    [2016-05-29 05:58:27 +0400] warn [cpbackup_transporter] Upload attempt failed: ABOR command successful
    at /usr/local/cpanel/Cpanel/ line 27.
        Cpanel::LoggerAdapter::warn(Cpanel::LoggerAdapter=HASH(0x8a3aa30), "Upload attempt failed: ABOR command successful\x{a}") called at /usr/local/cpanel/Cpanel/Backup/ line 492
        Cpanel::Backup::Queue::transport_backup::attempt_to_upload_file(Cpanel::Backup::Queue::transport_backup=HASH(0x8fe9004), Cpanel::Transport::Files::FTP=HASH(0x966411c), "/backup/weekly/2016-05-29/accounts/inxsnet.tar.gz", "/rose/weekly/2016-05-29/inxsnet.tar.gz", Cpanel::LoggerAdapter=HASH(0x8a3aa30)) called at /usr/local/cpanel/Cpanel/Backup/ line 254
        Cpanel::Backup::Queue::transport_backup::process_task(Cpanel::Backup::Queue::transport_backup=HASH(0x8fe9004), cPanel::TaskQueue::Task=HASH(0x9131588), Cpanel::LoggerAdapter=HASH(0x8a3aa30)) called at /usr/local/cpanel/3rdparty/perl/522/lib/perl5/cpanel_lib/cPanel/ line 585
        eval {...} called at /usr/local/cpanel/3rdparty/perl/522/lib/perl5/cpanel_lib/cPanel/ line 588
        cPanel::TaskQueue::__ANON__() called at /usr/local/cpanel/3rdparty/perl/522/lib/perl5/cpanel_lib/cPanel/ line 238
        eval {...} called at /usr/local/cpanel/3rdparty/perl/522/lib/perl5/cpanel_lib/cPanel/ line 238
        cPanel::StateFile::Guard::call_unlocked(cPanel::StateFile::Guard=HASH(0x8e01c08), CODE(0x9122cc8)) called at /usr/local/cpanel/3rdparty/perl/522/lib/perl5/cpanel_lib/cPanel/ line 593
        cPanel::TaskQueue::process_next_task(cPanel::TaskQueue=HASH(0x9042c60)) called at /usr/local/cpanel/bin/cpbackup_transporter line 151
        eval {...} called at /usr/local/cpanel/bin/cpbackup_transporter line 149
    I have it set to do 1 weekly and 1 monthly with 1 of each retained.

    I've set it to backup to a remote FTP location. I have it going to a specific sub-folder at the FTP site. And I have disabled Passive FTP. Clicking the "Validate" button gives me a green success notice.
    #1 Cloudpockets, May 31, 2016
    Last edited by a moderator: May 31, 2016
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    May 20, 2003
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator

Share This Page