The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issues with BlackBerry email notification

Discussion in 'E-mail Discussions' started by JamasWise, Dec 8, 2014.

  1. JamasWise

    JamasWise Member

    Joined:
    Jun 18, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    We recently migrated a new client from another cpanel host to our server. Everything works well after the migration except for email making it to the client's BlackBerry. Emails arrive on the device in bulk long after they have been received by our server. According to the client they aren't do anything to cause the emails to be retrieved. I think this is probably a configuration issue on the device side but wanted to rule out a server issue.

    In the maillog I can see the device doing an IMAP connection every 5 minutes. I don't see any indication of a failure.

    Under the clients cpanel interface under email the link for BlackBerry fast email shows this.

    Code:
    BlackBerry® FastMail Service
    
    Service is currently enabled (Version 2).
    
    If Research in Motion (RIM), recognizes you as a Mail Service Provider (MSP), this server can answer subscription requests at the following URLs:
    https://mail.example.com:2096/rim-bis/v1 (URLs Modified)
    https://webmail.example.com/rim-bis/v1 (URLs Modified)
    
    BlackBerry® FastMail Service Integration not available
    cPanel 11.25 uses BIS 2.6 or later to support real-time delivery to a BlackBerry® device. Currently, this functionality is not yet enabled on this server. For more information contact your system administrator.
    Is the last part normal. It seems to explain the issue we are having.

    I also tried to test our server by setting up a test email account under the clients domain. BlackBerry offers a Email Account Validation Tool (KB33444). That tool fails to validate, giving a cryptic error in the tool but on our server I can see it is attempting to establish a connection using SSLv3, which we have disabled on our server. Check the maillog I don't see any client connections failing for that reason.

    Server Info:
    WHM: 11.46.0 (Build 21)
    Email: Dovecot
    Users account has no security certificate installed. Instead we expect them to connect directly to the servers URL.

    Anything else you would suggest trying? Any way to get rid of the error message about FastMail service being not available.

    Thanks
    James
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Internal case number 142001 is open to address an issue where this message is incorrectly displayed in the X3 interface. The service is actually enabled by default, but you can run the following command if you want to ensure it's enabled:

    Code:
    /scripts/fastmail
    It's documented here:

    BlackBerry FastMail Service

    Have you tried using this functionality on the device?

    Thank you.
     
  3. JamasWise

    JamasWise Member

    Joined:
    Jun 18, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks, tried the script to make sure everything was setup correctly. I will report back if this changes anything.

    Unfortunately I don't have direct access to the device to check the settings. Also some BlackBerry forums suggested that some settings in the phone providers blackberry user account might need to be updated. I will get the client to confirm these as well.

    For our server we have a purchased security certificate for the main server URL. We instruct clients to connect directly to the server URL to avoid any security certificate warnings. I noticed that the BlackBerry FastMail Service page suggests:
    Code:
    https://mail.example.com:2096/rim-bis/v1 
    https://webmail.example.com/rim-bis/v1 as
    
    These are pointing at the clients domain which doesn't have a security certificate installed. I could add a self signed certificate to the domain to see if that helps. Or do you think this should forward to server correctly?

    I will report back any updates from the client.

    Thanks
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    The URLs should automatically redirect to the SSL certificate name installed for the cPanel/WHM/Webmail service depending on your settings under "Redirection" in "Tweak Settings".

    Thank you.
     
  5. JamasWise

    JamasWise Member

    Joined:
    Jun 18, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Just to close the loop on this one. The client ended up upgrading to a newer model and has not had the issue since. I have a feeling that they didn't update the settings on the old device correctly after the transition to our server. Thanks for the suggestions.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page