The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issues with Mailman/exim

Discussion in 'E-mail Discussions' started by rsutc, Mar 5, 2006.

  1. rsutc

    rsutc Well-Known Member

    Joined:
    Oct 8, 2002
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Not long ago I upgraded php in an Apache rebuild. I think the phpsuexec functionality was on before this, but got turned off. At any rate, I turned it (back?) on, then discovered that some variables could not be used in .htaccess and turned it back off again.
    Mail mavens

    I should also say that when I first set this box up, I did not have a mailman account for the box itself, and this situation persisted until after some people had set up mailman lists.

    OK, so here is the situation now. Some of those old lists are busy trying to send out mail as nobody and at the moment, many (all?) of the messages they send out cannot be delivered. Back comes an error message, usually saying that the domain cannot be reached, but the domain in question is often a good one, like gmail or aol. These error messages are coming to me as the box owner (presumably because they are going out from nobody) Needless to say, when I get up to hundreds of these, it is not pleasant.

    The question is, what now? Do I turn phpsuexec back on, killing off some .htaccess functionality? Is there a mailman/exim setting that I need to change?

    There is a thread here about mailman and nobody that suggests changing some settings in the mailpswrds (sp?) file of mailman, and I have tried that, but it does not seem to help.

    And, as another thought, given that things may get stuck on the queue, how long would it take before a change became noticeably effective?

    Rick
     
  2. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    You need to check your mailman install. Mailman does not, by default, send out as nobody.
     
  3. rsutc

    rsutc Well-Known Member

    Joined:
    Oct 8, 2002
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Well, actually, it does, if you set up mailman, then some accounts set up lists before you create a mailman list for the box itself (I don't know exactly why this is). Newer installations (of lists that is) don't have the problem, but older ones do. The question is, from someone who knows the inner workings of mailman, what is the easy fix to those old accounts, short of having the owners delete and reinstall?

    I solved the immediate problem of noboby being bounced. Turns out that it was a combination of the phpsuexec being turned off and a cPanel setting "prevent nobody from sending" still remaining.
     
Loading...

Share This Page