SOLVED Issues with the PThread (pecl)

Sarath Kumar R

Active Member
Oct 18, 2016
27
1
3
India
cPanel Access Level
Root Administrator
Hi,

IN EA4 we are facing issue in installing PThread via PECL. Please refer the below snippet for the error:

==
upload_2017-5-15_18-50-33.png
==

In EA3 we can enable ZTS by recompiling method. But ea4 we are using rpm method please let us know how to enable ZTS and PThread.
 

ChrisI

Technical Analyst II
Mar 24, 2014
67
12
83
cPanel Access Level
Root Administrator
Hello,

Easyapache does not currently support pthreads or ZTS. You should be able to build a custom apache RPM to add the support for those though. The instructions on how to build the RPMs are here. Keep in mind though that cPanel doesn't provide support for building those custom packages.

ea4.ninja

I also didn't see a feature request for that on our features site, so you may also want to add a feature request for that if you would like to see support for that added to cPanel.

cPanel Feature Requests

Thanks!
 
  • Like
Reactions: Sarath Kumar R