The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Isues with cPanel updates being blocked, license file missing or broken

Discussion in 'General Discussion' started by Alex_T, Jan 22, 2014.

  1. Alex_T

    Alex_T Registered

    Joined:
    Jan 21, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Greetings!

    Tanks for taking the time to read! I've been cracking away at this issue for a couple weeks now, and am ready to be done with it.

    I get the following sent to me at least once per day:

    Code:
    An error was detected which prevented updatenow from completing normally.
    Please review the enclosed log for further details
    
    ----------------------------------------------------------------------------------------------------
    
    [20140118.005604]   Detected version '11.32.2.25' from version file.
    [20140118.005604]   Target version set to '11.40.1.9'
    [20140118.005604]   Target version set to '11.32.7.3'
    [20140118.005604]   Need to upgrade to the LTS version before switching to another major version
    [20140118.005604]   Checking license
    [20140118.005605] E Blocker found: No license file found. Your cPanel software will not function properly. updates will be blocked until you fix this.
    [20140118.005605] ***** FATAL: An attempt to up/downgrade to 11.32.7.3 was blocked. Please review blockers.
    [20140118.005605] E Detected events which require user notification during updatenow. Will send iContact the log
    My cPanel version is WHM 11.40.1 (build 9). License is valid (double checked via the license checker). upcp runs without error (without --force). At a total loss for how to fix it. Seems to be related to an issue with the version file, but then again the E Blocker complains about a license file issue (but I can see how that might be affected by the version?).

    In any case, thanks for the help!

    - - - Updated - - -

    Also, (sorry for the double post)

    I've run /usr/local/cpanel/cpkeyclt in the past, to no avail.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Are you sure the message you are receiving is coming from your active cPanel server? For instance, the log you provided shows:

    However, you mentioned running cPanel version 11.40. Is it possible you have another server that is no longer active where the message is originating from?

    Thank you.
     
  3. Alex_T

    Alex_T Registered

    Joined:
    Jan 21, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hey!

    Thanks for the response :) I am without a doubt receiving this message from the server that reports it's version as 11.40.1.9.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page