The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

jailshell connection closed

Discussion in 'General Discussion' started by ck@phptalk, Dec 29, 2006.

  1. ck@phptalk

    ck@phptalk Active Member

    Joined:
    Nov 6, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Earth
    Hi,


    Just after logging into jailshell, connection immediately closed, without any message. Putty displays "connection closed by remote host"

    We are using FreeBSD AMD64 with latest stable WHM and Cpanel. /var/log/auth.log shows that authentication is succesful, so it is with cpanel jailshell itself. Root login is fine.


    Thanks in advance for your assistance.

    Regards,
     
  2. nvez

    nvez Active Member
    PartnerNOC

    Joined:
    Jul 17, 2006
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    You are probably seeing the error that says "You don't have access to SSH...", etc. That might be the thing appearing but because the connection is terminated, PuTTY closes it self. Double-check if the account does have SSH allowed.
     
  3. Henric

    Henric Member

    Joined:
    Feb 27, 2006
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    nvez is correct. You either don't have ssh access or you have wrongly configured shell access


    can you do the following command and paste the result here


    grep <username> /etc/passwd



    Regards
    Henric
     
  4. ck@phptalk

    ck@phptalk Active Member

    Joined:
    Nov 6, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Earth
    Hi,

    Thanks, but that is not the case.

    After logging into jailshall, i see /etc/motd welcome message, then connection is closed. Normal shell works perfectly for the same user.

    User has /etc/master.passwd record, no problem.


    Putty log shows
    ----------------------

    .
    2006-12-30 11:47:09 Access granted
    2006-12-30 11:47:09 Opened channel for session
    2006-12-30 11:47:09 Allocated pty (ospeed 38400bps, ispeed 38400bps)
    2006-12-30 11:47:09 Started a shell/command
    2006-12-30 11:47:09 Server exited on signal "SEGV"
    2006-12-30 11:47:09 All channels closed. Disconnecting
    2006-12-30 11:47:09 Server closed network connection
     
    #4 ck@phptalk, Dec 30, 2006
    Last edited: Dec 30, 2006
Loading...

Share This Page