JonMarkGo

Active Member
Sep 14, 2005
25
0
151
I'm trying to raise the limit on the number of open files for a user... I entered them in /etc/security/limits.conf and did ulimit -n as root but the user still has a limit of only 100 open files.
 

JonMarkGo

Active Member
Sep 14, 2005
25
0
151
I even edited the limit in /etc/profile but still can't seem to get above the 100 max.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
308
cPanel Access Level
Root Administrator
It's a chroot environment, hence will not read the global configuration files. Try setting the limits in /home/virtfs/user/etc/security/limits.conf or /home/virtfs/user/etc/profile
 

Babylon

Member
Aug 8, 2003
17
0
151
I had a similiar problem, and after editing /etc/profile and /etc/bashrc to remove the ulimit of 100 or to increase the ulimit on certain users, I was still finding problems. Security Center -> Shell Fork Bomb Protection -> Disable it, was what I had to go with. It would be nice to be able to add "trusted" users who can go beyond the usual limits.
 
Last edited: