The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Java applets not running (PLEASE help)

Discussion in 'General Discussion' started by Kikkorm, Sep 25, 2007.

  1. Kikkorm

    Kikkorm Member

    Joined:
    May 18, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    i'm using WHM 11.2.0 cPanel 11.11.0-S16999
    REDHAT Enterprise 3 i686 - WHM X v3.1.0 ;

    everything seems fine, except that java applets does not work into my websites . At first i tought it was an installation problem, but it happens with every kind of applet ; if i load it locally on my pc, the applet works perfectly . If i put it into my website, i always get an X over the Applet. No menus, no java chat, no sliding images..nothing works.

    I was told to install TOMCAT ; i did it into WHM>Cpanel>Plugins (i currently have TOMCAT5.5.9-1.4) , but the problem is still there. what should i do ?

    thanks
    kikkorm
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    From a shell (as root) type: ps auwx|grep tomcat

    If you get lines such as these as the result, then Tomcat is running:

    root 2250 0.0 0.0 5788 404 ? Ss Sep08 0:00 jsvc.exec -user tomcat -cp ./bootstrap.jar -Djava.endorsed.dirs=../common/endorsed -debug -outfile ../logs/catalina.out -errfile ../logs/catalina.err -verbose org.apache.catalina.startup.Bootstrap -security
    tomcat 2251 0.0 2.9 2387460 120932 ? Sl Sep08 6:50 jsvc.exec -user tomcat -cp ./bootstrap.jar -Djava.endorsed.dirs=../common/endorsed -debug -outfile ../logs/catalina.out -errfile ../logs/catalina.err -verbose org.apache.catalina.startup.Bootstrap -security


    If you don't get a result when you type 'ps auwx|grep tomcat', then Tomcat is not running. If it is not running, run: /scripts/restartsrv_tomcat while logged in as root.

    Then check to see if your websites are working and do a 'ps auwx|grep tomcat'

    If it still isnt' running, it's time to see why Tomcat doesn't want to run. To do that, check the Tomcat logs in this directory: /usr/local/jakarta/tomcat/

    Mike
     
  3. Kikkorm

    Kikkorm Member

    Joined:
    May 18, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi, i did what you wrote, but it still doesn't work.
    when opening logs this is what i get :

    root@cpanel [/usr/local/jakarta/tomcat/logs]# view catalina.out
    Java HotSpot(TM) Client VM warning: Can't detect initial thread stack location -
    find_vma failed
    [Opened /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/jsse.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/jce.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/charsets.jar]
    [Loaded java.lang.Object from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.io.Serializable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Comparable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.CharSequence from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.String from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.reflect.GenericDeclaration from /usr/local/jdk1.5.0_05/jre/lib
    /rt.jar]
    [Loaded java.lang.reflect.Type from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.reflect.AnnotatedElement from /usr/local/jdk1.5.0_05/jre/lib/r
    t.jar]
    [Loaded java.lang.Class from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Cloneable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.ClassLoader from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.System from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Throwable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Error from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.ThreadDeath from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Exception from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    "catalina.out" [readonly] 3002L, 296392C
    Java HotSpot(TM) Client VM warning: Can't detect initial thread stack location -
    ailed
    [Opened /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/jsse.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/jce.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/charsets.jar]
    [Loaded java.lang.Object from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.io.Serializable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Comparable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.CharSequence from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.String from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.reflect.GenericDeclaration from /usr/local/jdk1.5.0_05/jre/lib
    [Loaded java.lang.reflect.Type from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.reflect.AnnotatedElement from /usr/local/jdk1.5.0_05/jre/lib/r
    [Loaded java.lang.Class from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Cloneable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.ClassLoader from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.System from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Throwable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Error from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.ThreadDeath from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Exception from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.RuntimeException from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.security.ProtectionDomain from /usr/local/jdk1.5.0_05/jre/lib/rt.ja
    [Loaded java.security.AccessControlContext from /usr/local/jdk1.5.0_05/jre/lib/r
    [Loaded java.lang.ClassNotFoundException from /usr/local/jdk1.5.0_05/jre/lib/rt.
    [Loaded java.lang.LinkageError from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.NoClassDefFoundError from /usr/local/jdk1.5.0_05/jre/lib/rt.ja
    [Loaded java.lang.ClassCastException from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.ArrayStoreException from /usr/local/jdk1.5.0_05/jre/lib/rt.jar
    [Loaded java.lang.VirtualMachineError from /usr/local/jdk1.5.0_05/jre/lib/rt.jar
    [Loaded java.lang.OutOfMemoryError from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.StackOverflowError from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    Java HotSpot(TM) Client VM warning: Can't detect initial thread stack location -
    ailed
    [Opened /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/jsse.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/jce.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/charsets.jar]
    [Loaded java.lang.Object from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.io.Serializable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Comparable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.CharSequence from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.String from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.reflect.GenericDeclaration from /usr/local/jdk1.5.0_05/jre/lib
    [Loaded java.lang.reflect.Type from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.reflect.AnnotatedElement from /usr/local/jdk1.5.0_05/jre/lib/r
    [Loaded java.lang.Class from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Cloneable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.ClassLoader from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.System from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Throwable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Error from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.ThreadDeath from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Exception from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.RuntimeException from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.security.ProtectionDomain from /usr/local/jdk1.5.0_05/jre/lib/rt.ja
    [Loaded java.security.AccessControlContext from /usr/local/jdk1.5.0_05/jre/lib/r
    Java HotSpot(TM) Client VM warning: Can't detect initial thread stack location - find_vma failed
    [Opened /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/jsse.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/jce.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/charsets.jar]
    [Loaded java.lang.Object from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.io.Serializable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Comparable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.CharSequence from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.String from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.reflect.GenericDeclaration from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.reflect.Type from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.reflect.AnnotatedElement from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Class from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Cloneable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.ClassLoader from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.System from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Throwable from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Error from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.ThreadDeath from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Loaded java.lang.Exception from /usr/local/jdk1.5.0_05/jre/lib/rt.jar]


    next reply i add the other file log

    what is wrong with my tomcat ?:confused:
     
  4. Kikkorm

    Kikkorm Member

    Joined:
    May 18, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    jsvc.exec debug: user changed to 'tomcat'
    jsvc.exec debug: Using default JVM in /usr/local/jdk/jre/lib/i386/client/libjvm.
    so
    jsvc.exec debug: Attemtping to load library /usr/local/jdk/jre/lib/i386/client/l
    ibjvm.so
    jsvc.exec debug: JVM library /usr/local/jdk/jre/lib/i386/client/libjvm.so loaded
    jsvc.exec debug: JVM library entry point found (0x00E23680)
    jsvc.exec debug: +-- DUMPING JAVA VM CREATION ARGUMENTS -----------------
    jsvc.exec debug: | Version: 10002
    jsvc.exec debug: | Ignore Unrecognized Arguments: False
    jsvc.exec debug: | Extra options: 3
    jsvc.exec debug: | "-Djava.class.path=./bootstrap.jar" (0x00000000)
    jsvc.exec debug: | "-Djava.endorsed.dirs=../common/endorsed" (0x00000000)
    jsvc.exec debug: | "-verbose" (0x00000000)
    jsvc.exec debug: +-------------------------------------------------------
    jsvc.exec debug: Java VM created successfully
    jsvc.exec debug: Class org/apache/commons/daemon/support/DaemonLoader found
    jsvc.exec debug: Native methods registered
    jsvc.exec debug: Checking daemon
    jsvc.exec debug: Daemon checked successfully
    jsvc.exec debug: Daemon loaded successfully
    jsvc.exec debug: Daemon started successfully
    jsvc.exec debug: Waiting for a signal to be delivered
    jsvc.exec error: Service did not exit cleanly
    "catalina.err" [readonly] 43L, 2534C
    jsvc.exec debug: user changed to 'tomcat'
    jsvc.exec debug: Using default JVM in /usr/local/jdk/jre/lib/i386/client/libjvm.
    jsvc.exec debug: Attemtping to load library /usr/local/jdk/jre/lib/i386/client/l
    jsvc.exec debug: JVM library /usr/local/jdk/jre/lib/i386/client/libjvm.so loaded
    jsvc.exec debug: JVM library entry point found (0x00E23680)
    jsvc.exec debug: +-- DUMPING JAVA VM CREATION ARGUMENTS -----------------
    jsvc.exec debug: | Version: 10002
    jsvc.exec debug: | Ignore Unrecognized Arguments: False
    jsvc.exec debug: | Extra options: 3
    jsvc.exec debug: | "-Djava.class.path=./bootstrap.jar" (0x00000000)
    jsvc.exec debug: | "-Djava.endorsed.dirs=../common/endorsed" (0x00000000)
    jsvc.exec debug: | "-verbose" (0x00000000)
    jsvc.exec debug: +-------------------------------------------------------
    jsvc.exec debug: Java VM created successfully
    jsvc.exec debug: Class org/apache/commons/daemon/support/DaemonLoader found
    jsvc.exec debug: Native methods registered
    jsvc.exec debug: Checking daemon
    jsvc.exec debug: Daemon checked successfully
    jsvc.exec debug: Daemon loaded successfully
    jsvc.exec debug: Daemon started successfully
    jsvc.exec debug: Waiting for a signal to be delivered
    jsvc.exec error: Service did not exit cleanly
    jsvc.exec debug: user changed to 'tomcat'
    jsvc.exec debug: Using default JVM in /usr/local/jdk/jre/lib/i386/client/libjvm.
    jsvc.exec debug: Attemtping to load library /usr/local/jdk/jre/lib/i386/client/l
    jsvc.exec debug: JVM library /usr/local/jdk/jre/lib/i386/client/libjvm.so loaded
    jsvc.exec debug: JVM library entry point found (0x007FA680)
    jsvc.exec debug: +-- DUMPING JAVA VM CREATION ARGUMENTS -----------------
    jsvc.exec debug: | Version: 10002
    jsvc.exec debug: | Ignore Unrecognized Arguments: False
    jsvc.exec debug: | Extra options: 3
    jsvc.exec debug: | "-Djava.class.path=./bootstrap.jar" (0x00000000)
    jsvc.exec debug: | "-Djava.endorsed.dirs=../common/endorsed" (0x00000000)
    jsvc.exec debug: | "-verbose" (0x00000000)
    jsvc.exec debug: +-------------------------------------------------------
    jsvc.exec debug: Java VM created successfully
    jsvc.exec debug: Class org/apache/commons/daemon/support/DaemonLoader found
    jsvc.exec debug: Native methods registered
    jsvc.exec debug: Checking daemon
    jsvc.exec debug: user changed to 'tomcat'
    jsvc.exec debug: Using default JVM in /usr/local/jdk/jre/lib/i386/client/libjvm.
    jsvc.exec debug: Attemtping to load library /usr/local/jdk/jre/lib/i386/client/l
    jsvc.exec debug: JVM library /usr/local/jdk/jre/lib/i386/client/libjvm.so loaded
    jsvc.exec debug: JVM library entry point found (0x00E23680)
    jsvc.exec debug: +-- DUMPING JAVA VM CREATION ARGUMENTS -----------------
    jsvc.exec debug: | Version: 10002
    jsvc.exec debug: | Ignore Unrecognized Arguments: False
    jsvc.exec debug: | Extra options: 3
    jsvc.exec debug: | "-Djava.class.path=./bootstrap.jar" (0x00000000)
    jsvc.exec debug: | "-Djava.endorsed.dirs=../common/endorsed" (0x00000000)
    jsvc.exec debug: | "-verbose" (0x00000000)
    jsvc.exec debug: +-------------------------------------------------------
    jsvc.exec debug: Java VM created successfully
    jsvc.exec debug: Class org/apache/commons/daemon/support/DaemonLoader found
    jsvc.exec debug: Native methods registered
    jsvc.exec debug: Checking daemon
    jsvc.exec debug: Daemon checked successfully
    jsvc.exec debug: Daemon loaded successfully
    jsvc.exec debug: Daemon started successfully
    jsvc.exec debug: Waiting for a signal to be delivered
    jsvc.exec error: Service did not exit cleanly
    jsvc.exec debug: user changed to 'tomcat'
    jsvc.exec debug: Using default JVM in /usr/local/jdk/jre/lib/i386/client/libjvm.
    jsvc.exec debug: Attemtping to load library /usr/local/jdk/jre/lib/i386/client/l
    jsvc.exec debug: user changed to 'tomcat'
    jsvc.exec debug: Using default JVM in /usr/local/jdk/jre/lib/i386/client/libjvm.
    so
    jsvc.exec debug: Attemtping to load library /usr/local/jdk/jre/lib/i386/client/l
    ibjvm.so
    jsvc.exec debug: JVM library /usr/local/jdk/jre/lib/i386/client/libjvm.so loaded
    jsvc.exec debug: JVM library entry point found (0x00E23680)
    jsvc.exec debug: +-- DUMPING JAVA VM CREATION ARGUMENTS -----------------
    jsvc.exec debug: | Version: 10002
    jsvc.exec debug: | Ignore Unrecognized Arguments: False
    jsvc.exec debug: | Extra options: 3
    jsvc.exec debug: | "-Djava.class.path=./bootstrap.jar" (0x00000000)
    jsvc.exec debug: | "-Djava.endorsed.dirs=../common/endorsed" (0x00000000)
    jsvc.exec debug: | "-verbose" (0x00000000)
    jsvc.exec debug: +-------------------------------------------------------
    jsvc.exec debug: Java VM created successfully
    jsvc.exec debug: Class org/apache/commons/daemon/support/DaemonLoader found
    jsvc.exec debug: Native methods registered
    jsvc.exec debug: Checking daemon
    jsvc.exec debug: Daemon checked successfully
    jsvc.exec debug: Daemon loaded successfully
    jsvc.exec debug: Daemon started successfully
    jsvc.exec debug: Waiting for a signal to be delivered
    jsvc.exec error: Service did not exit cleanly
    jsvc.exec debug: user changed to 'tomcat'
    jsvc.exec debug: Using default JVM in /usr/local/jdk/jre/lib/i386/client/libjvm.
    jsvc.exec debug: Attemtping to load library /usr/local/jdk/jre/lib/i386/client/l
    jsvc.exec debug: JVM library /usr/local/jdk/jre/lib/i386/client/libjvm.so loaded
    jsvc.exec debug: JVM library entry point found (0x00E23680)
    jsvc.exec debug: +-- DUMPING JAVA VM CREATION ARGUMENTS -----------------
    jsvc.exec debug: | Version: 10002
    jsvc.exec debug: | Ignore Unrecognized Arguments: False
    jsvc.exec debug: | Extra options: 3
    jsvc.exec debug: | "-Djava.class.path=./bootstrap.jar" (0x00000000)
    jsvc.exec debug: | "-Djava.endorsed.dirs=../common/endorsed" (0x00000000)
    jsvc.exec debug: | "-verbose" (0x00000000)
    jsvc.exec debug: +-------------------------------------------------------
    jsvc.exec debug: Java VM created successfully
    jsvc.exec debug: Class org/apache/commons/daemon/support/DaemonLoader found
    jsvc.exec debug: Native methods registered
    jsvc.exec debug: Checking daemon
    jsvc.exec debug: Daemon checked successfully
    jsvc.exec debug: Daemon loaded successfully
    jsvc.exec debug: Daemon started successfully
    jsvc.exec debug: Waiting for a signal to be delivered
    jsvc.exec error: Service did not exit cleanly
    jsvc.exec debug: user changed to 'tomcat'
    jsvc.exec debug: Using default JVM in /usr/local/jdk/jre/lib/i386/client/libjvm.
    jsvc.exec debug: Attemtping to load library /usr/local/jdk/jre/lib/i386/client/l
    jsvc.exec debug: JVM library /usr/local/jdk/jre/lib/i386/client/libjvm.so loaded
    jsvc.exec debug: JVM library entry point found (0x007FA680)
    jsvc.exec debug: +-- DUMPING JAVA VM CREATION ARGUMENTS -----------------
    jsvc.exec debug: | Version: 10002
    jsvc.exec debug: | Ignore Unrecognized Arguments: False
    jsvc.exec debug: | Extra options: 3
    jsvc.exec debug: | "-Djava.class.path=./bootstrap.jar" (0x00000000)
    jsvc.exec debug: | "-Djava.endorsed.dirs=../common/endorsed" (0x00000000)
    jsvc.exec debug: | "-verbose" (0x00000000)
    jsvc.exec debug: +-------------------------------------------------------
    jsvc.exec debug: Java VM created successfully
    jsvc.exec debug: Class org/apache/commons/daemon/support/DaemonLoader found
    jsvc.exec debug: Native methods registered
    jsvc.exec debug: Checking daemon
    jsvc.exec debug: user changed to 'tomcat'


    the file is longer (too long to be posted), but it contains always the same procedure..
    what is my problem ? please give me some advice, thanks
     
  5. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36

    First I must ask, did you install the servlet for your domain?

    Tomcat has issues playing nice with whm especially on 64bit and CP11.

    Enable tomcat for system monitoring and see if it has a red light. Try restarting to get it green. If no success, then you may be detached from whm.

    First run the stop and start scripts. Give a pause between the two.
    /usr/local/jakarta/jakarta-tomcat-5.5.9/bin shutdown.sh
    check and kill any existing process prior to restarting
    ps aux | grep java
    now run the startup script
    /usr/local/jakarta/jakarta-tomcat-5.5.9/bin sh startup.sh
    check if the process and options exist
    ps aux | grep java

    Provided you did install servlets for your domain, see if your test script works.
    http://domain.com/jsptest.jsp ( note: NO www. )

    If your test page renders, then your java is indeed working. You may have issues with your web-inf.
     
  6. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    If the OP isn't seeing Tomcat running when doing 'ps auwwx|grep tomcat', then his servlets aren't going to work period.

    Of course, Kikkorm did _not_ share with us the results of a 'ps auwwx|grep tomcat'. It certainly would help to know whether it is running or not.

    And based upon what he said in his first post, it looks like they are not running x86_64. I am also familiar with the problem with installing Tomcat on x86_64 but was able to work around that and get it installed. But that shouldn't be the problem on his system.

    Mike
     
  7. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Something differing between your logs and mine are the line:

    jsvc.exec error: Service did not exit cleanly

    In my .err log, with a successful startup I see:

    jsvc.exec debug: Java VM created successfully
    jsvc.exec debug: Class org/apache/commons/daemon/support/DaemonLoader found
    jsvc.exec debug: Native methods registered
    jsvc.exec debug: Daemon loaded successfully
    jsvc.exec debug: Daemon started successfully
    jsvc.exec debug: Waiting for a signal to be delivered
    jsvc.exec debug: create_tmp_file: /tmp/9180.jsvc_up


    In your .err log with a failing startup I see:

    jsvc.exec debug: Class org/apache/commons/daemon/support/DaemonLoader found
    jsvc.exec debug: Native methods registered
    jsvc.exec debug: Checking daemon
    jsvc.exec debug: Daemon checked successfully
    jsvc.exec debug: Daemon loaded successfully
    jsvc.exec debug: Daemon started successfully
    jsvc.exec debug: Waiting for a signal to be delivered
    jsvc.exec error: Service did not exit cleanly


    Looks like yours never gets to the point where it creates the /tmp/xxxx.jsvc_up file. I wonder if it is not being permitted to create that file in your /tmp dir. I'm not Tomcat expert.

    Mike

     
  8. asiams

    asiams Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hokkaido, JAPAN
    Same problem here after I upgraded to Cpanel 11

    I have done

    root@server23 [/home/ast-tech/www]# ps auwx|grep tomcat
    root 21542 0.0 0.0 1660 316 ? Ss 19:41 0:00 jsvc.exec -user tomcat -cp ./bootstrap.jar -Djava.endorsed.dirs=../common/endorsed -debug -outfile ../logs/catalina.out -errfile ../logs/catalina.err -verbose org.apache.catalina.startup.Bootstrap -security
    tomcat 21543 1.0 1.5 291496 32620 ? Sl 19:41 0:04 jsvc.exec -user tomcat -cp ./bootstrap.jar -Djava.endorsed.dirs=../common/endorsed -debug -outfile ../logs/catalina.out -errfile ../logs/catalina.err -verbose org.apache.catalina.startup.Bootstrap -security
    root 22804 0.0 0.0 5036 636 pts/1 S+ 19:49 0:00 grep tomcat

    Seems like tomcat is running fine.

    However, when I did jsptest.jsp at http://ast-tech.co.jp/jsptest.jsp

    I get:

    HTTP Status 404 - /jsptest.jsp

    type Status report

    message /jsptest.jsp

    description The requested resource (/jsptest.jsp) is not available.
    Apache Tomcat/5.5.9

    I tried to reinstall servlet from WHM, but it said it is already installed.

    When I check the log for tomcat :


    root@server23 [/usr/local/jakarta/tomcat/logs]# view catalina.out
    Java HotSpot(TM) Client VM warning: Can't detect initial thread stack location - find_vma failed
    [Opened /usr/local/jdk1.5.0_05/jre/lib/rt.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/jsse.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/jce.jar]
    [Opened /usr/local/jdk1.5.0_05/jre/lib/charsets.jar]
    [Loaded java.lang.Object from shared objects file]
    [Loaded java.io.Serializable from shared objects file]
    [Loaded java.lang.Comparable from shared objects file]
    [Loaded java.lang.CharSequence from shared objects file]
    [Loaded java.lang.String from shared objects file]
    [Loaded java.lang.reflect.GenericDeclaration from shared objects file]
    [Loaded java.lang.reflect.Type from shared objects file]
    [Loaded java.lang.reflect.AnnotatedElement from shared objects file]
    [Loaded java.lang.Class from shared objects file]
    [Loaded java.lang.Cloneable from shared objects file]
    [Loaded java.lang.ClassLoader from shared objects file]
    [Loaded java.lang.System from shared objects file]
    [Loaded java.lang.Throwable from shared objects file]
    [Loaded java.lang.Error from shared objects file]
    [Loaded java.lang.ThreadDeath from shared objects file]
    [Loaded java.lang.Exception from shared objects file]
    [Loaded java.lang.RuntimeException from shared objects file]
    [Loaded java.security.ProtectionDomain from shared objects file]
    [Loaded java.security.AccessControlContext from shared objects file]
    Type :quit<Enter> to exit Vim

    The first line of log says: Can't detect initial thread stack location - find_vma failed.

    Does anyone have any idea about what could be wrong?

    Thanks in advance.

    asiams
     
  9. asiams

    asiams Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hokkaido, JAPAN
    Restart report for tomcat

    When I tried to restart tomcat, here is what I got:

    root@server23 [/usr/local/jakarta/tomcat/logs]# /scripts/restartsrv_tomcat
    jsvc debug: +-- DUMPING PARSED COMMAND LINE ARGUMENTS --------------
    jsvc debug: | Detach: True
    jsvc debug: | Show Version: No
    jsvc debug: | Show Help: No
    jsvc debug: | Check Only: Disabled
    jsvc debug: | Run as service: No
    jsvc debug: | Install service: No
    jsvc debug: | Remove service: No
    jsvc debug: | JVM Name: "null"
    jsvc debug: | Java Home: "null"
    jsvc debug: | PID File: "/var/run/jsvc.pid"
    jsvc debug: | User Name: "tomcat"
    jsvc debug: | Extra Options: 3
    jsvc debug: | "-Djava.class.path=./bootstrap.jar"
    jsvc debug: | "-Djava.endorsed.dirs=../common/endorsed"
    jsvc debug: | "-verbose"
    jsvc debug: | Class Invoked: "org.apache.catalina.startup.Bootstrap"
    jsvc debug: | Class Arguments: 2
    jsvc debug: | "-security"
    jsvc debug: | ""
    jsvc debug: +-------------------------------------------------------
    jsvc debug: user changed to 'tomcat'
    jsvc debug: User 'tomcat' validated
    jsvc debug: Home not specified on command line, using environment
    jsvc debug: Attempting to locate Java Home in /usr/local/jdk
    jsvc debug: Attempting to locate VM configuration file /usr/local/jdk/jre/lib/jvm.cfg
    jsvc debug: Attempting to locate VM configuration file /usr/local/jdk/lib/jvm.cfg
    jsvc debug: VM configuration file not found
    jsvc debug: Attempting to locate VM library /usr/local/jdk/jre/lib/i386/classic/libjvm.so
    jsvc debug: Attempting to locate VM library /usr/local/jdk/jre/lib/i386/client/libjvm.so
    jsvc debug: Java Home located in /usr/local/jdk
    jsvc debug: +-- DUMPING JAVA HOME STRUCTURE ------------------------
    jsvc debug: | Java Home: "/usr/local/jdk"
    jsvc debug: | Java VM Config.: "null"
    jsvc debug: | Found JVMs: 1
    jsvc debug: | JVM Name: "null"
    jsvc debug: | "/usr/local/jdk/jre/lib/i386/client/libjvm.so"
    jsvc debug: +-------------------------------------------------------
    jsvc debug: Using default JVM in /usr/local/jdk/jre/lib/i386/client/libjvm.so
    jsvc debug: Invoking w/ LD_LIBRARY_PATH=/usr/local/lib:/usr/local/jdk/jre/lib/i386/client:/usr/local/jdk/jre/lib/i386
    jsvc.exec debug: +-- DUMPING PARSED COMMAND LINE ARGUMENTS --------------
    jsvc.exec debug: | Detach: True
    jsvc.exec debug: | Show Version: No
    jsvc.exec debug: | Show Help: No
    jsvc.exec debug: | Check Only: Disabled
    jsvc.exec debug: | Run as service: No
    jsvc.exec debug: | Install service: No
    jsvc.exec debug: | Remove service: No
    jsvc.exec debug: | JVM Name: "null"
    jsvc.exec debug: | Java Home: "null"
    jsvc.exec debug: | PID File: "/var/run/jsvc.pid"
    jsvc.exec debug: | User Name: "tomcat"
    jsvc.exec debug: | Extra Options: 3
    jsvc.exec debug: | "-Djava.class.path=./bootstrap.jar"
    jsvc.exec debug: | "-Djava.endorsed.dirs=../common/endorsed"
    jsvc.exec debug: | "-verbose"
    jsvc.exec debug: | Class Invoked: "org.apache.catalina.startup.Bootstrap"
    jsvc.exec debug: | Class Arguments: 2
    jsvc.exec debug: | "-security"
    jsvc.exec debug: | ""
    jsvc.exec debug: +-------------------------------------------------------
    jsvc.exec debug: user changed to 'tomcat'
    jsvc.exec debug: User 'tomcat' validated
    jsvc.exec debug: Home not specified on command line, using environment
    jsvc.exec debug: Attempting to locate Java Home in /usr/local/jdk
    jsvc.exec debug: Attempting to locate VM configuration file /usr/local/jdk/jre/lib/jvm.cfg
    jsvc.exec debug: Attempting to locate VM configuration file /usr/local/jdk/lib/jvm.cfg
    jsvc.exec debug: VM configuration file not found
    jsvc.exec debug: Attempting to locate VM library /usr/local/jdk/jre/lib/i386/classic/libjvm.so
    jsvc.exec debug: Attempting to locate VM library /usr/local/jdk/jre/lib/i386/client/libjvm.so
    jsvc.exec debug: Java Home located in /usr/local/jdk
    jsvc.exec debug: +-- DUMPING JAVA HOME STRUCTURE ------------------------
    jsvc.exec debug: | Java Home: "/usr/local/jdk"
    jsvc.exec debug: | Java VM Config.: "null"
    jsvc.exec debug: | Found JVMs: 1
    jsvc.exec debug: | JVM Name: "null"
    jsvc.exec debug: | "/usr/local/jdk/jre/lib/i386/client/libjvm.so"
    jsvc.exec debug: +-------------------------------------------------------
    jsvc.exec debug: Running w/ LD_LIBRARY_PATH=/usr/local/lib:/usr/local/jdk/jre/lib/i386/client:/usr/local/jdk/jre/lib/i386
    jsvc.exec debug: redirecting stdout to ../logs/catalina.out and stderr to ../logs/catalina.err
    root@server23 [/usr/local/jakarta/tomcat/logs]#

    Does this help some?

    Thanks.

    asiams
     
  10. asiams

    asiams Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hokkaido, JAPAN
    viewing catalina.err

    When I view catalina.err, I get this error:

    jsvc.exec error: Service did not exit cleanly

    Does this give some clue?

    Thanks.

    asiams
     
  11. asiams

    asiams Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hokkaido, JAPAN
    Found the answer

    Here was an answer from other post on this forum:

    This did the trick to solve the problem for me.

    Thank you.

    asiams
     
  12. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    That sounds more like a problem with the <object> tag used on the web page to load the applet. Applets run client side, they are not dependent upon Tomcat. Since you can load the applet locally from your PC, then Tomcat is not an issue (unless you are actually running Tomcat on your PC?).

    Verify:

    1. The <object> tag used to load the applet is correct. Sun used to have a utility on their web site that would actually create this tag for you.

    2. Verify the applet is uploaded properly to your website

    3. Verify there are no permissions issues with the applet file on your web site

    What do you see in the Apache logs when attempting to load the applet via your web site?
     
  13. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Kenneth,

    I had the same problem. My web.xml file contained duplicate entries for the httpservlet and httpservlets items.

    I event went as far as 'Install Servlets' on a site that I didn't really need them on, just so it would install them and then give me a jsptest.jsp page to try. This failed as well until I removed the duplicate httpservlet and httpservlets sections from web.xml.


    Mike
     
  14. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Yes, that would cause problems for Tomcat, a server side technology for handling Java Servlets.

    However, this thread was about Applets, which are run by executing within a user's browser, by loading the JVM on the visitors PC. Yes, I can think of a few instances where Tomcat is required for an Applet, but those are very custom situations. The information given in the original post suggests this is not one of those instances.

    This leads me to the conclusion that something totally unrelated to Tomcat is causing the error.
     
  15. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Of course you're right. I see now that I didn't read the OP like I should have, or I would not have responded in this thread. On the other hand, there are other recent threads regarding the issue that I and others have had occur - and those are legitimate issues with duplicate entries in web.xml.

    Looks like I and others should never have sent the OP down the road to installing Tomcat since his local java issue on his machine :(

    Mike
     
  16. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    When it comes to various technologies, it's amazing we can keep any of it straight.
     
Loading...

Share This Page