The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Javascript broken after move [moved]

Discussion in 'General Discussion' started by royli57, Sep 15, 2005.

  1. royli57

    royli57 Active Member

    Joined:
    Mar 3, 2005
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Javascript broken after move

    Hello

    I recently moved a fairly simple website from an old host to our hosting service.

    Everything moved over well, except the javascript stopped working. The link below, for instance, is supposed to jump from cartoon to cartoon with javascript:

    http://naenministries.org/chip/index.shtml

    Does anyone have any ideas why it might have stopped working?

    thanks

    Roy
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    JavaScript code is executed client-side, so it will have no bearing whatsoever on the host you are using.

    However in order for the client to receive the JavaScript code in order to execute it, you have to have the relevant code in the correct place on the server, as defined by your HTML.

    Code:
    <script src="../assets/js/swapimage.js" type="text/JavaScript" language="JavaScript"></script>
    <script src="../assets/js/swapimagerestore.js" type="text/JavaScript" language="JavaScript"></script>
    <script src="../assets/js/preloadimages.js" type="text/JavaScript" language="JavaScript"></script>
    <script src="../assets/js/showHideLayers.js" type="text/JavaScript" language="JavaScript"></script>
    <script src="../assets/js/findobject.js" type="text/JavaScript" language="JavaScript"></script>
    <script src="../assets/js/jumpMenu.js" type="text/JavaScript" language="JavaScript"></script>
    Make sure all these files, and most likely the last one, are where they should be.
     
  3. royli57

    royli57 Active Member

    Joined:
    Mar 3, 2005
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the detailed help. I think you are right about that last JS page, there is some broken code on it. Thanks for scanning the pages to help find the problem!

    Roy
     
Loading...

Share This Page