The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Javascript issues

Discussion in 'General Discussion' started by chipper, Aug 9, 2007.

  1. chipper

    chipper Member

    Joined:
    Aug 9, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Hello All,

    I am new to the cpanel wave. I work at a ISP and we recently starting using cPanel. We have ran into a issue where javascripts are not working for clients. They work on our older hosting servers where we configured apache manually? Any ideas on what would keep this from working normally? I'm sure it is something silly. I did notice in WHM to build java into apache, but it said it had to be installed first....and there was my curve ball.

    -Cameron
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Are you talking about JSP or Javascript? JSP is server-side whereas JavaScript is client-side and would typically not be affected by a migration to a new web server.

    If you are talking about JSP, are you using Tomcat or mod_resin?
     
  3. chipper

    chipper Member

    Joined:
    Aug 9, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    It is using Javascript, which I know is client-side, but I can't figure out for the life of me, why it works on other servers, just not on our new cpanel server.
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Off hand, the only thing I can think of is perhaps an issue of different paths. For example, if you permited IP/~username on the old server but not on the new server. Additionally, if the old server was Windows and the new server is cPanel/WHM, note that *nix is case-sensitive with paths whereas Windows is not.
     
Loading...

Share This Page