Job for mariadb.service failed after data directory move

hooumeri

Registered
Jan 30, 2017
1
0
1
Finland
cPanel Access Level
Root Administrator
Hi everyone,

I'm running MariaDB10.0.1, today I had to move my data-directory because the default path (var/lib/mysql) is in my root partition and was causing it to fill up. I moved the data-directory to /home/mysql.

I have checked the file permissions and I think they are correct. I have obviously also specified the new path for the data-directory. What I also did is edit MariaDB settings to allow the database directory to be in the /home/ folder.

I am now getting the following error:


Code:
[[email protected] etc]# systemctl start mariadb
Job for mariadb.service failed because a fatal signal was delivered to the control process. See "systemctl status mariadb.service" and "journalctl -xe" for details.
[[email protected] etc]# systemctl status mariadb.service
● mariadb.service - MariaDB database server
   Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/mariadb.service.d
           └─migrated-from-my.cnf-settings.conf
   Active: activating (auto-restart) (Result: signal) since Mon 2017-01-30 10:51:26 CET; 954ms ago
  Process: 10205 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=killed, signal=ABRT)
  Process: 10154 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ]   && systemctl set-environment _WSREP_START_POSITION=$VAR || exit 1 (code=exited, status=0/SUCCESS)
  Process: 10143 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
 Main PID: 10205 (code=killed, signal=ABRT)
   CGroup: /system.slice/mariadb.service

Jan 30 10:51:26 raccoon.snowblind.pro systemd[1]: Failed to start MariaDB database server.
Jan 30 10:51:26 raccoon.snowblind.pro systemd[1]: Unit mariadb.service entered failed state.
Jan 30 10:51:26 raccoon.snowblind.pro systemd[1]: mariadb.service failed.
I've scavenged all of the threads on the web I could find about this error, but neither of the fixes seem to work. Any ideas?

Thanks in advance :)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
I have obviously also specified the new path for the data-directory. What I also did is edit MariaDB settings to allow the database directory to be in the /home/ folder.
Hello,

Could you let us know the specific entries you added to the /etc/my.cnf file?

Thank you.