Joomla SMTP failing on new server, same settings as old server

smatt

Active Member
Apr 28, 2016
26
2
3
london
cPanel Access Level
Root Administrator
Hi all,

Wondering if some one could help me find the cause of this problem. I have a Joomla site on our old server (Cent 6.7, WHM 11.58), everything works fine, it connects to our mail server and sends fine with SMTP.

Have copied the site to our new server (CloudLinux, WHM 11.58) but the joomla site is failing to send using SMTP.

SMTP credentials are the same on both sites. On the new server, SMTP is not restricted. The mailserver itself does not restrict login by IP, neither server is blocked by the firewall.

What/where could be blocking please?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Have copied the site to our new server (CloudLinux, WHM 11.58) but the joomla site is failing to send using SMTP.

SMTP credentials are the same on both sites. On the new server, SMTP is not restricted. The mailserver itself does not restrict login by IP, neither server is blocked by the firewall.
Hello,

Do you notice any specific error message during the failed message delivery? Have you been able to send out email via SMTP through traditional mailing methods (E.g. Email client, Webmail)?

Thank you.
 

smatt

Active Member
Apr 28, 2016
26
2
3
london
cPanel Access Level
Root Administrator
Hi Michael,

Thanks for following up on this. I didn't realise CSF also has an SMTP_Block restriction that supercedes WHMs. Disabling that solved the problem.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
I'm happy to see you were able to resolve the issue. Thank you for updating us with the outcome.