The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

jsptest.jsp not reponding

Discussion in 'General Discussion' started by alamsher, Nov 25, 2014.

  1. alamsher

    alamsher Registered

    Joined:
    Nov 25, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi I have installed servlets support via WHM to my domain domain.pw.

    In /home/bgx3/public_html I have a basic default java application structure.
    jsptest.jsp is available there that I'm trying to access via browser

    Here is the complete URL: [removed]

    It just keeps on loading and loading forever. No response.

    Furthermore: If I type wrong URL server gives me error immediately i.e.

    Not Found
    The requested URL /jsptest.abc was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    Please let me know where should I look into, I have root level acccess to SSH console, WHM and cPanel.

    Thanks
     
    #1 alamsher, Nov 25, 2014
    Last edited by a moderator: Nov 25, 2014
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,474
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  3. alamsher

    alamsher Registered

    Joined:
    Nov 25, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Yes. I've gone through these docs.

    Problem is:
    I can't access [domain]/jsptest.jsp as it just does not respond (browser keeps showing loading). After a whlie following response is shown on brwoser:

    Bad Gateway

    The proxy server received an invalid response from an upstream server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    Furthermore:
    I tried to remove jsp support by running /scripts/remservlets --domain .... and then
    browser rendered contents of [doamin]/jsptest.jsp as text just fine immediately.

    Afterwards:
    I again installed jsp support by running /scripts/addservlets --domain ... and then

    Once again [doamin]/jsptest.jsp is not responding.

    Any clues?

    Thanks
     
  4. alamsher

    alamsher Registered

    Joined:
    Nov 25, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    A support ticket was logged, where tomcat was rebuilt. Now the issue has been resolved.
     
Loading...
Similar Threads - jsptest jsp reponding
  1. Ivo Danic
    Replies:
    2
    Views:
    564

Share This Page