The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Just noticed this ... <defunct>

Discussion in 'General Discussion' started by Daky, Sep 6, 2011.

  1. Daky

    Daky Well-Known Member

    Joined:
    May 22, 2005
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    Since yesterday when i do ps aux on my server i see many lines like this:

    root 28013 0.0 0.0 0 0 ? Z Sep05 0:00 [cpanel-auth.pl] <defunct>
    root 28097 0.0 0.0 0 0 ? Z Sep05 0:00 [cpanel-auth.pl] <defunct>
    root 28098 0.0 0.0 0 0 ? Z Sep05 0:00 [cpanel-auth.pl] <defunct>
    root 28326 0.0 0.0 0 0 ? Z Sep05 0:00 [cpanel-auth.pl] <defunct>
    root 28929 0.0 0.0 0 0 ? Z Sep05 0:00 [cpanel-listuser] <defunct>
    root 29045 0.0 0.0 0 0 ? Z Sep04 0:00 [cpanel-auth.pl] <defunct>
    root 29063 0.0 1.0 119492 41964 ? S Sep05 0:00 spamd child
    root 29133 0.0 0.0 0 0 ? Z Sep04 0:00 [cpanel-auth.pl] <defunct>
    root 29144 0.0 0.0 0 0 ? Z Sep04 0:00 [cpanel-auth.pl] <defunct>
    root 29783 0.0 0.0 0 0 ? Z Sep05 0:00 [cpanel-listuser] <defunct>
    root 30250 0.0 0.0 0 0 ? Z 12:03 0:00 [cpanel-listuser] <defunct>

    I never seen it before, what is this? How to 'fix' this?

    Regards
     
  2. JawadArshad

    JawadArshad Well-Known Member
    PartnerNOC

    Joined:
    Apr 8, 2008
    Messages:
    447
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    PK
    cPanel Access Level:
    DataCenter Provider
    Do you happen to have CDP backups enabled?

     
  3. Daky

    Daky Well-Known Member

    Joined:
    May 22, 2005
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    R1Soft? Yes
     
  4. JawadArshad

    JawadArshad Well-Known Member
    PartnerNOC

    Joined:
    Apr 8, 2008
    Messages:
    447
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    PK
    cPanel Access Level:
    DataCenter Provider
    These processes are related to R1Soft and not cPanel if I am not mistaken. Is this server the central buagent server and/or is loaded. You might want to restart R1Soft Buagent services and see if this stops the processes. If these defunct processes continue to spawn, I'd recommend contacting R1Soft support.

     
  5. Daky

    Daky Well-Known Member

    Joined:
    May 22, 2005
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Thank you :)
     
  6. JawadArshad

    JawadArshad Well-Known Member
    PartnerNOC

    Joined:
    Apr 8, 2008
    Messages:
    447
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    PK
    cPanel Access Level:
    DataCenter Provider
    You're welcome.

     

Share This Page