Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED kcarectl ip was already used for a trial license

Discussion in 'General Discussion' started by benito, Mar 6, 2019.

  1. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    350
    Likes Received:
    7
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello! I started to get these emails from one of our server where not have installed cloudlinux or KernelCare.

    Subject: Cron <root@hostname> /usr/bin/kcarectl -q --auto-update

    Body: The IP bla.bla.bla.bla was already used for a trial license on 2019-02-05​

    I only check one of the solutions proposed by security advisor, we need to purchase KernelCare? Tought this patch was free.

    Thanks
    Cristian
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. GOT

    GOT Get Proactive! PartnerNOC

    Joined:
    Apr 8, 2003
    Messages:
    1,453
    Likes Received:
    178
    Trophy Points:
    193
    Location:
    Chesapeake, VA
    cPanel Access Level:
    DataCenter Provider
    Kernelcare does require a subscription You can get it from lots of places. CPa el store has them along with CloudLinux who makes it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    350
    Likes Received:
    7
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    I know, but i tought the only fix available vía cPanel security advisor install a free minimal version os KernelCare.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. ES - George

    ES - George Well-Known Member PartnerNOC

    Joined:
    Jun 12, 2011
    Messages:
    175
    Likes Received:
    22
    Trophy Points:
    68
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,124
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @benito


    This issue occurs when you install kernelcare's symlink protection on an unsupported kernel, or a kernel that was supported and then was subsequently updated and became unsupported for a period of time. Can you run the following:
    Code:
     uname -r
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    350
    Likes Received:
    7
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello Lauren,

    [root@fy-atlanta ~]# uname -r

    3.10.0-957.5.1.el7.x86_64
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,124
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @benito

    When was the last time you received one of those messages? Kernelcare should support that kernel at this moment for the free symlink protection patch:

    KernelCare Directory

    What output do you get when you run the following:

    Code:
    kcarectl --patch-info
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    350
    Likes Received:
    7
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello Lauren, just FYI i installed this using the cPanel security advisor, not manually with cloudlinux instructions.

    I enabled this on 2/5 and started to get this warnings exactly after one month.

    Thanks

    Code:
    [root@fy-atlanta ~]# kcarectl --patch-info
    No patches applied, but some are available, run 'kcarectl --update'.
    [root@fy-atlanta ~]# kcarectl --update
    Downloading updates
    The IP bla.bla.bla.bla was already used for a trial license on 2019-02-05
    [root@fy-atlanta ~]# 
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,124
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @benito

    That's fine, the way it gets installed is the same in either case. Can you run the following and let me know the output?

    Code:
    kcarectl --set-patch-type free --update
    
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    350
    Likes Received:
    7
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    Code:
    [root@fy-atlanta ~]# kcarectl --set-patch-type free --update
    'free' patch type selected
    Downloading updates
    Patch level 2 applied. Effective kernel version
    Updates already downloaded
    Kernel is safe
    [root@fy-atlanta ~]#
    :-D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    cPanelLauren likes this.
  11. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,124
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @benito

    This looks good! Please let me know if you run into any other issues with it.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    504
    Likes Received:
    5
    Trophy Points:
    318
    Can I piggyback off this ticket pls?!

    kcarectl --update
    The IP xxx.xxx.xx.xxx was already used for a trial licence on 2018-10-07

    kcarectl --set-patch-type free
    'free' patch type is unavailable for your kernel

    So it seems I can't use the 'free' or the 'extra' version?

    uname -r
    3.10.0-962.3.2.lve1.5.24.10.e17.x86_64

    fyi: I'm running CloudLinux 7.6 and WHM v78.0.21

    Thx.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,124
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @spaceman

    There's no reason to use the free symlink protection patch when you're running CloudLinux which already has this functionality built into the kernel.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    504
    Likes Received:
    5
    Trophy Points:
    318
    Thanks for that @cPanelLauren .

    How best then to stop/disable the daily warnings I'm getting that say:

    "The IP xxx.xxx.xx.xxx was already used for a trial license on 2018-10-07"

    If I switch to the free version, then I get a daily warning that says:

    "The `free` type patch is not found for your kernel. Please select existing patch type"

    I really want to disable this completely, and/or the warning that generates this.

    Thx again.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,124
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @spaceman

    CloudLinux comes with the security the free patch provides already, if you're not going to be using the full version of kernelcare there's no point in retaining the package. You can remove it with the following (per the instructions provided in CloudLinux documentation:

    Code:
    yum remove kernelcare
    
    
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    504
    Likes Received:
    5
    Trophy Points:
    318
    Gr8, thx.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    cPanelLauren likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice