The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

keepalive and server load?

Discussion in 'General Discussion' started by tshin, Aug 27, 2005.

  1. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    i have a strange problem here.

    when the "keepalive" is on
    within about 5 minutes the server load gets up to 7,8,or higher.
    then within about 1 hour,the server load goes crazy to 40,50,or higher.

    so i try to leave the "keepalive" off.
    no server load problem,but another problem.
    only few times, my client can open the webpage,other time,the pages cannot display.
    i get crazy this time.

    can you help me?
    thank you and thank you very much.

    i'll wait online.
     
  2. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    any suggestions please?
     
  3. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    Take a look at the apache docs at what keepalive does. Basically with it on if you visit a website it will let you download all of the images from and other files from the same connection, with it off you have to open a seperate connection to apache for every seperate file. Depending on the situation this may be good or bad. With it off the connections close a lot faster then if it is on. I will routinely use both on servers depending on the configuration.
     
  4. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    thank you eth00

    my server hosts lot of forums
    so i want to turn the "keepalive" off
    some days before,when off,all ok.
    but these two days,it forces me to turn "keepalive" on.

    so,what causes this?
    how can i turn it on again?

    thank you.
     
  5. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    For most servers keepalive should remain on, with yours it sounds like you should leave it on. Look at adjusting/tweaking the other timeouts and your website. You may even look at a 2nd webserver for images if you are very busy.
     
  6. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    thank you again.

    but my situation is
    the images are not much.
    more is the php scripts and the forums.
    i've been heard that,if there're many forums,it should be off.
    the strange thing is,before today,the "keepalive" is off and server works very fine.server load is very low.
    but today the web cant display when "keepalive" is off,only if it's on.

    i get crazy.

    can you give me some suggestions?
    thank you.
    maybe bother you.. :( :(
     
  7. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    any help please?
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    AS eth00 has said, you should probably leave KeepAlives enabled, but read up on tweaking the associated settings (Timeout, etc) to suit your environment. Apache docs are, as always, over here: http://www.apache.org
     
Loading...

Share This Page