sh4ka

Well-Known Member
May 12, 2005
444
0
166
Uruguay
cPanel Access Level
DataCenter Provider
I tried to upgrade my kernel, downloaded the last kernel rpm for my single processor server, then i run:

Downloaded the kernel: up2date --download --force kernel

Installing the kernel...

[email protected] [/var/spool/up2date]# rpm -ihv kernel-2.4.xxxxxx.EL.i686.rpm

Preparing... ########################################### [100%]
1:kernel ########################################### [100%]
stdin: is not a tty
stdin: is not a tty
stdin: is not a tty
grubby fatal error: unable to find a suitable template

[email protected] [/var/spool/up2date]#

What are this errors ??? and how can I fix it to upgrade my kernel

stdin: is not a tty
stdin: is not a tty
stdin: is not a tty
grubby fatal error: unable to find a suitable template


thkz!
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
32
473
Go on, have a guess
You should speak to your datacenter about that (presuming that you've rented your server from one) and have them fix it as they haven't installed the OS boot loader correctly, in this case GRUB. In the meantime, you'll have to copy an existing entry in /etc/grub.conf and modify it for the new kernel, but you need to know what you're doing when you do that before you attempt to reboot your server.