Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Kernel Upgrade Message still remains...

Discussion in 'General Discussion' started by Suan, Dec 20, 2003.

  1. Suan

    Suan Member

    Joined:
    Apr 28, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    I have already updated, and here's a the grub info.

    I have rebooted, but the message stil remains. Please help.
     
  2. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Atlanta, GA
    Change the line "default=3" to "default=0" and reboot. With your current config, you are still booting off an old kernel. You can run 'uname -a' at a command line to verify the kernel you have boot upon.
     
  3. Suan

    Suan Member

    Joined:
    Apr 28, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    Thanks for your help. :)

    Did exactly that, but still no luck. :(
     
  4. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    repost your grub.conf
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Suan

    Suan Member

    Joined:
    Apr 28, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You have a /boot partition. This means that
    # all kernel and initrd paths are relative to /boot/, eg.
    # root (hd0,0)
    # kernel /vmlinuz-version ro root=/dev/hda2
    # initrd /initrd-version.img
    #boot=/dev/hda
    default=0
    timeout=10
    splashimage=(hd0,0)/grub/splash.xpm.gz
    title Red Hat Linux (2.4.20-24.9)
    root (hd0,0)
    kernel /vmlinuz-2.4.20-24.9 ro root=/dev/hda2
    initrd /initrd-2.4.20-24.9.img
    title Red Hat Linux (2.4.20-19.7)
    root (hd0,0)
    kernel /vmlinuz-2.4.20-19.7 ro root=/dev/hda2
    initrd /initrd-2.4.20-19.7.img
    title Red Hat Linux (2.4.20-18.7)
    root (hd0,0)
    kernel /vmlinuz-2.4.20-18.7 ro root=/dev/hda2
    initrd /initrd-2.4.20-18.7.img
    title Red Hat Linux (2.4.18-27.7.x)
    root (hd0,0)
    kernel /vmlinuz-2.4.18-27.7.x ro root=/dev/hda2
    initrd /initrd-2.4.18-27.7.x.img
     
  6. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    according to the grub.conf that will boot with the new kernel

    i see no reason for it to not boot with it
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,504
    Likes Received:
    1
    Trophy Points:
    318
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Since you have nothing left to lose, I would suggest one of the following:

    Remove everything below:

    title Red Hat Linux (2.4.20-24.9)
    root (hd0,0)
    kernel /vmlinuz-2.4.20-24.9 ro root=/dev/hda2
    initrd /initrd-2.4.20-24.9.img

    This, in effect, gives only one entry and jives with default=0

    OR

    Verify this is the first line in /etc/fstab

    LABEL=/1 / ext3 defaults,usrquota 1 1

    If so, change

    kernel /vmlinuz-2.4.20-24.9 ro root=/dev/hda2

    to

    kernel /vmlinuz-2.4.20-24.9 ro root=LABEL=/1

    We all know, the way things are supposed to work and the way they actually work, are not necessarily the same thing.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    318
    Couple things.. First i noticed your previous kernels were for the 7.* series of redhat, did you update your server to redhat 9? ( Im pretty sure the 8 kernel would be there if you did ) so if yo uare on 7.* make sure you are installing the right kernel. Second, are you sure your server doesn't user lilo?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Luke87

    Luke87 Member

    Joined:
    Dec 16, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    151
    I had this problem with 2 machines, so the data centre did it :]
     
  10. mta

    mta Well-Known Member

    Joined:
    Sep 19, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    156
    Hi all
    I had the same problem
    & i tried setting default to 0 (it was 1) and it just workied fine


    Thx all:)
     
  11. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    318
    Yes, if the install DOES edit your grib or lilo, it normally does not automatically select the new kernel. You need to make those changes your self. And just for reference ( grub.conf ), 0 is the first in the list, 1 is second, 2 is third, and so on and so forth.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. Suan

    Suan Member

    Joined:
    Apr 28, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    I think I know what's causing the problem. It seems to be running RH 7.3.

    Can anyone recommend which is the latest kernel for 7.3? Or is it worth upgrading to 9?

    Might be running lilo too.
     
  13. Suan

    Suan Member

    Joined:
    Apr 28, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    Alright, I have got the latest kernel for 7.3; but have a problem. I blindly installed the rpm for 9 before, so when I try to install the 7.3 kernel, I get:

    package kernel-2.4.20-24.9 (which is newer than kernel-2.4.20-24.7) is already installed

    Can anyone please suggest the safest way out?
     
  14. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    318
    As long as the server is not running that kernel right now, you should be able to remove it with rpm -e packagename then install the new one with rpm -ivh filename
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. Suan

    Suan Member

    Joined:
    Apr 28, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    Having tried that, I get this error:

    error: "kernel-2.4.20-24.9" specifies multiple packages


    Now what can I do?
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice