SOLVED kex_exchange_identification: read: Connection reset by peer

JIKOmetrix

Well-Known Member
Apr 3, 2007
183
34
178
Hello,

I'm trying to disable password auth for SSH and enable key authentication.

I created user green-set keys in cpanel user ssh->manage keys and authorized the key.

If I use a remote terminal to connect:

ssh -i /Users/user_remote/.ssh/id_rsa [email protected]-server-domain-123.net -p 2222

The server does have a non-standard SSH port of 2222.

I get this error in my remote terminal:

[email protected] % ssh -i /Users/user_remote/.ssh/id_rsa [email protected]-server-domain-123.net -p 2222
kex_exchange_identification: read: Connection reset by peer
Connection reset by 123.456.789.123 port 2222
[email protected] Desktop %

Why would the remote server reset the connection for key auth and allow password?

Thanks,
Mike
 
Last edited by a moderator:

JIKOmetrix

Well-Known Member
Apr 3, 2007
183
34
178
Thanks, I checked there were not blocks. I did find an extra ALLOW at the end of my host entry in the hosts.allow file. After that I disabled password auth and the key auth started to work.
 
  • Like
Reactions: cPRex and techAMIGO