Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Lame nameservers

Discussion in 'Bind/DNS/Nameserver' started by benito, Aug 27, 2006.

  1. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    323
    Likes Received:
    4
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    Hi!

    Those are my firsts experiences with DNS clustering on Cpanel. I have two servers running cpanel.

    Server 1: ns1.example.com 1.1.1.1
    Server 2: ns2.example.com 2.2.2.2

    Everything looks fine and its working. DNS changes are replicated on each server, no rndc errors. But on dnsreports i get:

    ERROR: You have one or more lame nameservers. These are nameservers that do NOT answer authoritatively for your domain. This is bad; for example, these nameservers may never get updated. The following nameservers are lame: 2.2.2.2

    How i can remove the Lame Nameservers error ? What i miss when i set my second dns server ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    323
    Likes Received:
    4
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    up to the roof.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    1
    Trophy Points:
    166
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    The problem probably lies in the individual DNS zone settings for the domain in question.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    323
    Likes Received:
    4
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    I solved the lame problem adding a line to named.conf:

    server2:
    listen-on { 2.2.2.2; };

    But now, lame problem is fixed adding that line ! Now i only have two warns.

    And
    Maybe i need to work with my firewall.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    1
    Trophy Points:
    166
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Sounds like you are on the right track, since the connection was refused.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    323
    Likes Received:
    4
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    It fail even if my firewall are disabled, maybe i miss anything else on named.conf :(
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Jesepi

    Jesepi Member

    Joined:
    Sep 1, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    I am also having this problem, it started 2 days ago out of nowhere... nothing on the server had been changed relating to DNS... I fixed my issue by downloading the site's files (all static pages and images, no dynamic content or databases) deleting the account, and then recreating it with the same settings as I used to set it up.

    The bad thing is, today the same problem arose with yet another domain on the machine. I am trying to figure out what would be causing this if nobody is playing with the dns settings.
     
  8. Jesepi

    Jesepi Member

    Joined:
    Sep 1, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    I fixed my issue, this is what I did:

    - ssh into the server, and viewed /etc/named.conf
    - did a search for the domain and found that it was not present in the file
    - went to the bottom of the file and added:

    Code:
    zone "domainthatwasmissing.com" {
            type master;
            file "/var/named/domainthatwasmissing.com.db";
    };
    
    -saved and closed the file


    -went and looked inside the /var/named directory and confirmed that there was a file that was called domainthatwasmissing.com.db

    -ran the following:
    scripts/restartsrv_named
    scripts/restartsrv_bind


    The site loads fine now
     
  9. XzaB

    XzaB Active Member

    Joined:
    Nov 20, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Egypt, Cairo
    is very weired from me to update thread since 2006
    anyway I faced the same issue today on cPanel DNS Only, and it been fixed by same method as u said by using
    WHM >> Synchronize DNS Records
    Ticking for "Synchronize zones that are not configured on this server"
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice