Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Language Problem after php 5.3 to 5.6

Discussion in 'General Discussion' started by Bulent Tekcan, Nov 2, 2016.

Tags:
  1. Bulent Tekcan

    Bulent Tekcan Well-Known Member

    Joined:
    May 11, 2004
    Messages:
    180
    Likes Received:
    0
    Trophy Points:
    166
    Hello,

    We have a big vbulletin forum on our server and our language (Turkish) code ISO-8859-9 in language settings. But after update Apache and Php 5.3 to 5.6 special character problem starting. We never change anything our forum and other things only build apache and php.

    Why this problem occured ? If I edit message from forum message seems to OK and only save post is OK. It is very interesting.

    If we return php 5.3 problem gone again.

    Regards
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,713
    Likes Received:
    1,883
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You will likely receive more feedback to this issue on the VBulletin support forums, as the issue likely relates to their application's interaction with PHP 5.6:

    Home - vBulletin Community Forum

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Bulent Tekcan

    Bulent Tekcan Well-Known Member

    Joined:
    May 11, 2004
    Messages:
    180
    Likes Received:
    0
    Trophy Points:
    166
    This is not vbulletin related, because our all php based web page also problem after php update. I'm sure php 5.6 buggy for htmlspecialcharacters but I didn't find any solutions
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,713
    Likes Received:
    1,883
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The "default_charset" value in the php.ini file changes to UTF-8 in PHP 5.5 and PHP 5.6. You can change it back the default PHP 5.4 setting by updating your system's php.ini file to unset the default value:

    Code:
    default_charset = ""
    Information on editing your php.ini file is available at:

    How to Edit Your php.ini File - cPanel Knowledge Base - cPanel Documentation

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice