The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Large Attachments with Horde not sending

Discussion in 'E-mail Discussions' started by Hack, Jul 10, 2007.

  1. Hack

    Hack Member

    Joined:
    May 18, 2005
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    My server recently updated to Version 11 and one of my customers can not send emails larger than a few megs. I had previously configured horde to allow large email attachemnts. He can upload to the server and it shows up in the tmp dir, but when he goes to send it displays a error message. In horde it says that the attachements can be up to 25megs and the file he is sending is only 18 megs. I also looked in the exim logs and could not find where it tried to receive it. So I am to think its getting stuck between webmail and the smtp daemon. Any ideas where to look for changes that need to be made?
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Horde is coded in PHP, and since it is served by cpsrvd, it is governed by /usr/local/cpanel/3rdparty/etc/php.ini

    Ensure that the PHP configuration allows files up to 25 megabytes to be uploaded.
     
  3. Hack

    Hack Member

    Joined:
    May 18, 2005
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Follow up on checking settings

    I looked in /usr/local/cpanel/3rdparty/etc/php.ini and here are the important settings I think.

    I increased them some as below and still same thing.

    memory_limit = 55M
    file_uploads = On
    upload_max_filesize = 50M
    post_max_size = 55M

    Under IE7 after the file is uploaded then it goes to the next page where it shows that the file was added as an attachment and I verified it has been placed in the /tmp dir. Then when you hit the send message button, it pauses for a few seconds and then it goes to the dumb ie7 problem page.

    Under FF2 doing all the same things, but when you hit the send message button it goes to a blank screen that has http://www.domain.com:2095/horde/imp/compose.php?uniq=xm2zvjcafa8 as the title and whne I try to view the source of the page, it just says that the page contains post data and will be resent.

    Thanks for any more ideas.
     
  4. Hack

    Hack Member

    Joined:
    May 18, 2005
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    More log info

    After much rooting around in the system I found the file /usr/local/cpanel/logs/error_log

    which is showing the following error

    Tue Jul 10 15:22:55 2007 trace [ExpVar]: Deprecated use of DOMAIN as a variable in DOMAIN : ./webmail/x/index.html at /usr/local/cpanel/Cpanel/Logger.pm line 35
    Cpanel::Logger::cplog('Deprecated use of DOMAIN as a variable in DOMAIN : ./webmail/x/i...', 'trace', 'ExpVar', 1) called at /usr/local/cpanel/Cpanel/ExpVar.pm line 156
    Cpanel::ExpVar::expvar('DOMAIN') called at cpanel.pl line 3762
    main::doprint('DOMAIN', 0) called at cpanel.pl line 1340
    main::exectag('<cpanel print="DOMAIN">') called at cpanel.pl line 4343
    main::dotag(undef) called at cpanel.pl line 4232
    main::cpanel_parseblock('SCALAR(0x8ed4f8c)') called at cpanel.pl line 4186
    main::cpanel_parse('GLOB(0x9a021c8)') called at cpanel.pl line 990
    FATAL: emalloc(): Unable to allocate 25098011 bytes

    The server has plenty of memory 2gigs and I set the php values high, so not sure why I'm getting this errors

    root@host10 [/usr/local/cpanel/logs]# free
    total used free shared buffers cached
    Mem: 2075228 443816 1631412 0 40512 238664
    -/+ buffers/cache: 164640 1910588
    Swap: 2031608 0 2031608
     
  5. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Hmm... unless someone else out there has any ideas, it might be time to submit a ticket on this one.
     
  6. manuxer

    manuxer Active Member

    Joined:
    Aug 16, 2006
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    I have the same problem with horde, on cpanel 11.12.0 C17046
    The problem was solved? is there a ticket for it!?
    Thank you!
     
  7. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Anyone find a way to fix.

    I'm having the same problem after upgrading to WHM 11.2.0 cPanel 11.11.0-S16999.
     
  8. gfisch

    gfisch Member

    Joined:
    Aug 9, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Montreal
    Same problem here

    I just tried with a 15 Meg file and got the memory error.

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 42439519 bytes) in /usr/local/cpanel/3rdparty/lib/php/Net/SMTP.php on line 788

    WHM 11.11.0 cPanel 11.15.0-R17853
    FEDORA 4 x86_64 on standard - WHM X v3.1.0

    /usr/local/cpanel/3rdparty/etc/php.ini:
    post_max_size = 55M
    file_uploads = On
    upload_max_filesize = 50M
     
  9. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Is there a fix available ?

    /usr/local/cpanel/3rdparty/etc/php.ini

    seems to be not responsible for that error.

    max_upload is 50M
    max_execution_time 480
    memory_limit 512M

    These settings doesn't matter. Always
    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 42439519 bytes) in /usr/local/cpanel/3rdparty/lib/php/Net/SMTP.php on line 788

    if the attachment is bigger than about 10MB.

    Strange :(
     
  10. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    The settings have to be increased within the following files :

    /usr/local/cpanel/3rdparty/etc/php.ini
    /usr/local/cpanel/3rdparty/etc/horde/php.ini

    and within "Tweak Settings" ;)
     
  11. sabarishks

    sabarishks Active Member

    Joined:
    Jun 29, 2007
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
  12. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
  13. sabarishks

    sabarishks Active Member

    Joined:
    Jun 29, 2007
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Are u Still getting same error ?

    It should work... :(
     
  14. sabarishks

    sabarishks Active Member

    Joined:
    Jun 29, 2007
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
  15. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    New WHM version got the following tweak settings:

    PHP max execution time for cPanel PHP execution in seconds (default 90)

    PHP Max Post Size for cPanel PHP in Megabytes (default 55M)

    PHP Max Upload Size for cPanel PHP in Megabytes (default 50M)

    but no memory_limit.

    Each morning the memory_limit within
    /usr/local/cpanel/3rdparty/etc/php.ini
    /usr/local/cpanel/3rdparty/etc/horde/php.ini
    is set to 128M.

    No chance to retain 512M.
     
  16. sabarishks

    sabarishks Active Member

    Joined:
    Jun 29, 2007
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Have you tried my previous post.

    The Output should be as this.

    quota -s cpanel-horde
    Disk quotas for user cpanel-horde (uid 32003): none

    If this is the O/P, then the problem lies somewhere else. Have searched my forum ?

    I have posted a lot of Fix regarding this !!!
     
Loading...

Share This Page