The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

last update = MYSQL error in 10 server

Discussion in 'General Discussion' started by Creazioni, Aug 15, 2003.

  1. Creazioni

    Creazioni Well-Known Member

    Joined:
    Jan 5, 2003
    Messages:
    133
    Likes Received:
    0
    Trophy Points:
    16
    /usr/bin/mysqladmin: connect to server at 'localhost' failed error: 'Access denied for user: 'root@localhost' (Using password: YES)' 3.38 Megabytes

    i fixed this into 1 so

    control /root/.my.cnf
    i reset password from cpanel
    restart mysql
    but sometime problem to restart (sock)

    therefore
    rm -f /tmp/mysql.sock
    rm -f /var/tmp/mysql.sock
    /etc/init.d/mysql stop
    rm -f /var/lib/mysql/mysql.sock
    /etc/init.d/mysql start
    ln -s /var/lib/mysql/mysql.sock /tmp/mysql.sock
    ln -s /var/lib/mysql/mysql.sock /var/tmp/mysql.sock

    THANKS TO SOME THREAD INTO THIS FORUM


    BUT....
    there is a fast solution without do all this?

    cPanel.net Support Ticket Number:
     
  2. khoonchee

    khoonchee Well-Known Member
    PartnerNOC

    Joined:
    Oct 2, 2002
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    We have this problem in our server and tried the above method but no luck..:(

    cPanel.net Support Ticket Number:
     
  3. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Which update are you referring to?

    layer2.cpanel.net? Which one?
     
  4. Creazioni

    Creazioni Well-Known Member

    Joined:
    Jan 5, 2003
    Messages:
    133
    Likes Received:
    0
    Trophy Points:
    16
    Yesterday i've not this problem
    therefore i think
    > /scripts/upcp (14 AUGUST in USA and 15 AUGUST here in ITALY)

    now i update CPANEL to (*.4.1), but nothing
    i wait > /scripts/upcp of this morning (16 august)

    cPanel.net Support Ticket Number:
     
  5. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Well I had no problem with the latest upcp update (1.5 hours ago)

    And just upgraded to the latest stable release. No problems with mysql here either.

    cPanel.net Support Ticket Number:
     
  6. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    cPanel 7.4.1-S74 update for me.

    only happend on the Redhat 8.0 server.

    the above didn't work for me also.

    cPanel.net Support Ticket Number:
     
  7. Creazioni

    Creazioni Well-Known Member

    Joined:
    Jan 5, 2003
    Messages:
    133
    Likes Received:
    0
    Trophy Points:
    16
  8. server4sale

    server4sale Member

    Joined:
    Aug 6, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I have same problem on 25 servers..... :(
    I hate to login into each server and manually fix it
    WHats weired is even if u downgrade to ver 3 and then to ver 4 problem keep exist

    cPanel.net Support Ticket Number:
     
  9. Creazioni

    Creazioni Well-Known Member

    Joined:
    Jan 5, 2003
    Messages:
    133
    Likes Received:
    0
    Trophy Points:
    16
    i don0't know is ok

    from CPANEL FAQ

    Make sure root pass is in /root/.my.cnf

    This is usually the first root pass the box was given once cpanel is installed.

    If it still does not work, you will need to reset the mysqld root pass.

    First, stop the mysqld, usually /etc/rc.d/init.d/mysql stop

    Then stop chkservd to keep it from interfering with mysqld while you work on it
    with /etc/rc.d/init.d/chkservd stop

    Start up mysqld , but, without the grant tables,

    mysqld --skip-grant-tables -u mysql &

    Then change the pass..

    mysql -u root mysql
    UPDATE user SET Password=PASSWORD('new_password') WHERE user='root';
    FLUSH PRIVILEGES;

    Now you just killall -9 mysqld and start it up normally with it's safe_mysqld
    script..

    cPanel.net Support Ticket Number:
     
  10. Creazioni

    Creazioni Well-Known Member

    Joined:
    Jan 5, 2003
    Messages:
    133
    Likes Received:
    0
    Trophy Points:
    16
    i hope in a fast way and solution
    becuase my solution of last night is too long

    cPanel.net Support Ticket Number: cPanel ID# 21103
     
  11. khoonchee

    khoonchee Well-Known Member
    PartnerNOC

    Joined:
    Oct 2, 2002
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    Hi Creazioni ,

    Thansk for the tip but still no luck after trying the above steps.:(

    cPanel.net Support Ticket Number:
     
  12. Creazioni

    Creazioni Well-Known Member

    Joined:
    Jan 5, 2003
    Messages:
    133
    Likes Received:
    0
    Trophy Points:
    16
    i cry!!!!

    i will try (tommorow)


    /etc/init.d/mysql stop

    mysqld_safe --skip-grant-tables

    THEN INTO WHM I RESET MYSQL PASSWORD

    /etc/init.d/mysql start

    cPanel.net Support Ticket Number: 21103
     
  13. hs-jon

    hs-jon Registered

    Joined:
    Dec 15, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    We had special characters in our password (eg: !@#$%^&*) which caused the password to not work even after being reset using the instructions in previous replies to this topic.

    After setting the password to "test" it all worked so we removed the special characters from the password and it was all fine.



    MrPHP.com.au - we make code

    cPanel.net Support Ticket Number:
     
  14. Creazioni

    Creazioni Well-Known Member

    Joined:
    Jan 5, 2003
    Messages:
    133
    Likes Received:
    0
    Trophy Points:
    16
    for me THIS WORK!!!!
    (history)

    into SSH
    /etc/init.d/mysql stop
    /etc/rc.d/init.d/chkservd stop
    mysqld_safe --skip-grant-tables

    INTO CPANEL CHANGE PASSWORD
    INTO CPANEL RESTART MYSQL

    into SSH
    /etc/rc.d/init.d/chkservd restart
     
    #14 Creazioni, Aug 16, 2003
    Last edited: Aug 16, 2003
  15. ksstudio

    ksstudio Member

    Joined:
    Aug 25, 2001
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    It works!

    I follow these stpes:
    Make sure root pass is in /root/.my.cnf
    This is usually the first root pass the box was given once cpanel is installed.
    If it still does not work, you will need to reset the mysqld root pass.
    First, stop the mysqld, usually /etc/rc.d/init.d/mysql stop
    Then stop chkservd to keep it from interfering with mysqld while you work on it with /etc/rc.d/init.d/chkservd stop
    Start up mysqld , but, without the grant tables,
    mysqld --skip-grant-tables -u mysql &
    Then change the pass..

    mysql -u root mysql UPDATE user SET Password=PASSWORD('new_password') WHERE user='root';
    FLUSH PRIVILEGES;
    Now you just killall -9 mysqld and start it up normally with it's safe_mysqld script..

    and update your password in /root/.my.cnf


    Cheers,


    Chan

    cPanel.net Support Ticket Number:
     
  16. asuservice

    asuservice Well-Known Member

    Joined:
    Oct 24, 2001
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Thanks HS-Jon

    Thanks for your post HS-Jon ... I had tried every fix I could find here in this forum and a couple others but none worked. Your post was the one for me!!!

    cPanel.net Support Ticket Number:
     
  17. Creazioni

    Creazioni Well-Known Member

    Joined:
    Jan 5, 2003
    Messages:
    133
    Likes Received:
    0
    Trophy Points:
    16
    IF >>>>

    into SSH
    /etc/init.d/mysql stop
    /etc/rc.d/init.d/chkservd stop
    mysqld_safe --skip-grant-tables

    INTO CPANEL CHANGE PASSWORD
    INTO CPANEL RESTART MYSQL

    into SSH
    /etc/rc.d/init.d/chkservd restart

    >>>> DON'T WORK

    delete into root mysql password Special character
    like told in a post
    cPanel.net Support Ticket Number:
     
  18. server4sale

    server4sale Member

    Joined:
    Aug 6, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    OK this is most simplest fix. Update to latest version of cpanekl
    Use WHM change LOcal mysql Root passwd.
    If you get an error first time try to change it again.

    DONOT use any special charater like $%^
    This works for me on 20+ servers i ve

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page