The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

latest cpanel installer broken

Discussion in 'General Discussion' started by linux_terror, Jun 6, 2007.

  1. linux_terror

    linux_terror Member
    PartnerNOC

    Joined:
    Jul 25, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello cpanel,
    please re-add File::Copy::Recursive to your perl deps in the latest cpanel installer, it is broken and does not install cpanel without it.

    post install...

    [root@server cpins]# ls /usr/local/cpanel/
    3rdparty src

    running /scripts/perlinstaller File::Copy::Recursive
    and re-execing the cpanel install seems to take care of the problem and cpanel installs properly.

    Thanks,
    linux_terror
     
  2. linux_terror

    linux_terror Member
    PartnerNOC

    Joined:
    Jul 25, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Sigh, BSD::Resource YAML::Syck and version are missing as well, reinstalling again.

    linux_terror
     
  3. linux_terror

    linux_terror Member
    PartnerNOC

    Joined:
    Jul 25, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    File::Find::Rule as well, last post got checkperlmodules to kick over, pukes after entropychat on File::Find::Rule
    I think this should finally do it.

    linux_terrror
     
  4. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    new installer out right after new RELEASE is out
     
  5. linux_terror

    linux_terror Member
    PartnerNOC

    Joined:
    Jul 25, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Filesys::Virtual is the last missing module, also cpdan, umm, you realize NOONE can install fresh cpanel's right now, and your going to wait for a new release? doesnt seem like that'd really help business. I'm not really satisfied with that answer considering it just took me 3 hours to install a box, and I do this multiple times a day. 2 cents, case closed. later gator.

    linux_terror
     
  6. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    Thanks for the info :)

    Its building right now, the install script has to have a new script available, to make it available a build has to go out. Its a bit complicated to explain but rest assured we're working very hard to get it out ASAP.

    I'm sorry you had a difficult time, but I think you've misunderstood what requiring a new build to create a new install script means :) Plus I've been helping everyone experiencing this and all that needed done was a simple call to cpan based on the "Can't find X/Y/Z.pm in @INC" it only added about ten minutes to the ones I assisted. Perhaps there was another delay, like a long time to compile something or ?

    I'd be happy to review your ticket and see what could have been done to expedite service.

    What is your ticket number?
     
  7. utropic

    utropic Well-Known Member

    Joined:
    Aug 6, 2005
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    how about this one?

    Can't locate Whostmgr/Accounts/Create.pm in @INC (@INC contains: /usr/local/cpanel /scripts /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at /scripts/wwwacct line 10. BEGIN failed--compilation aborted at /scripts/wwwacct line 10.
     
  8. utropic

    utropic Well-Known Member

    Joined:
    Aug 6, 2005
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    got this after a 'upcp'

    Installing /var/spool/up2date/libxml-devel-1.8.17-9.2.i386.rpm...
    Can't locate YAML/Syck.pm in @INC (@INC contains: /scripts /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at /scripts/cPScript/DataStore.pm line 11.
    BEGIN failed--compilation aborted at /scripts/cPScript/DataStore.pm line 11.
    Compilation failed in require at /scripts/compilers line 8.
    BEGIN failed--compilation aborted at /scripts/compilers line 8.


    what is going on????
     
  9. oinkmedia

    oinkmedia Well-Known Member

    Joined:
    Jul 5, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    SW London (UK)
    cPanel & WHM broken!

    cPanel & WHM broken! What's going on?
     
  10. thesmacker11

    thesmacker11 Member

    Joined:
    Jan 12, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Testing connection speed (12 servers)...(this could take a while)................Done
    Ping:12.205 Testing connection speed to 69.90.250.34 using pureperl...(210875.00 bytes/s)...Done
    Ping:13.201 Testing connection speed to 69.90.250.35 using pureperl...(210875.00 bytes/s)...Done
    Ping:25.598 Testing connection speed to 69.72.164.155 using pureperl...(210875.00 bytes/s)...Done
    Ping:27.213 Testing connection speed to 69.72.164.152 using pureperl...(6342.11 bytes/s)...Done
    Ping:38.999 Testing connection speed to 8.10.120.130 using pureperl...(70291.67 bytes/s)...Done
    5 usable mirrors located
    Fetching http://httpupdate.cpanel.net/pub/CPAN/index.html (0)....@69.90.250.34......connected......receiving...70%...100%......Done
    /scripts/perlbootstrap: line 3: /scripts/realperlinstaller: No such file or directory


    is my error i cant even install it
     
  11. utropic

    utropic Well-Known Member

    Joined:
    Aug 6, 2005
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    that was a 3-hr chore.

    I had everything set to manual updates too.......
     
  12. oinkmedia

    oinkmedia Well-Known Member

    Joined:
    Jul 5, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    SW London (UK)
    My servers are back online with working cPanels (appear to be working as normal) by using putty to login to the server as root, navigate to the /scripts/ directory and running the command 'perl perlinstaller'. All now seems fine. Hope this helps.
     
  13. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Give it a shot now, we've updated the installer to work better with the latest changes in RELEASE.
     
  14. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    That perl module is not installed and the module ensurer wasn't run, simply install it:

    cpan YAML::Syck
     
  15. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    How can I reproduce this?

    The modules are all there and so should be in /usr/local/cpanel

    http://httpupdate.cpanel.net/cpanelsync/CURRENT/scripts/wwwacct
    http://httpupdate.cpanel.net/cpanelsync/CURRENT/cpanel/Whostmgr/Accounts/Create.pm

    http://httpupdate.cpanel.net/cpanelsync/RELEASE/scripts/wwwacct
    http://httpupdate.cpanel.net/cpanelsync/RELEASE/cpanel/Whostmgr/Accounts/Create.pm

    http://httpupdate.cpanel.net/cpanelsync/EDGE/scripts/wwwacct
    http://httpupdate.cpanel.net/cpanelsync/EDGE/cpanel/Whostmgr/Accounts/Create.pm
     
  16. nothings_found

    nothings_found Registered

    Joined:
    Apr 4, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    So is it fixed? I just went over and installed a plesk box to try out their software but nothings compares to cpanel. Im probably gonna reinstall again.

    :mad:
     
  17. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Should be fine now.

    If you have any issues, support is always ready to assist.

    https://tickets.cpanel.net/submit/
     
  18. dv2support

    dv2support Member
    PartnerNOC

    Joined:
    Oct 9, 2002
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I agree. Your support is always great. :D


    Luis @ GNAX
     
  19. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Found a few more problems.. They will be solved once the new RELEASE build is published
     
  20. dv2support

    dv2support Member
    PartnerNOC

    Joined:
    Oct 9, 2002
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Is that why the installer files have new timestamps?
    cpanel-universal-install-v11.sea (Thu Jun 7 21:09:49 2007)
    cpanel-universal-install.sea (Thu Jun 7 21:09:49 2007)
     
Loading...

Share This Page