The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

latest Cpanel upcp fix

Discussion in 'General Discussion' started by lost, Dec 24, 2004.

  1. lost

    lost Well-Known Member

    Joined:
    Aug 19, 2003
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    hello,
    if anyone experiences that bind won't start suddenly or 'named' is an unknown user and therefore prevents 'named' from being started, here's the fix.

    add this entry to your /etc/passwd file.

    named:x:25:25:Named:/var/named:/sbin/nologin

    The details why a cpanel update breaks this are unknown at this time. The only known thing is that it is a cpanel update and therefore, by definition, screws stuff up.

    L
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Are you running RHE? If so, the recent RHE3.4 update included a new version of bind and the installation of that could have caused the problems that you're seeing (since cPanel runs up2date during the upcp run).
     
  3. Roberto

    Roberto Active Member

    Joined:
    Jul 9, 2003
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Yep, Chirpy is correct.

    I have fixed this using different methods on different servers.

    Upgrading to the latest Stable build worked on one machine, while on another I had to upgrade to the latest current build worked on another server while I had to download and reinstall these three RPMS from rpmfind.net on another server:

    bind, bind-libs, bind-utils

    Hope this helps!
     
Loading...

Share This Page