The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Latest Kernel not up to date?

Discussion in 'CloudLinux' started by russelld, Apr 27, 2014.

  1. russelld

    russelld Member

    Joined:
    Apr 10, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    After installing CloudLinux, I received the following error.

    The CloudLinux support checked out the grub config and says this is a CP issue because the kernel installed in the latest kernel.

    whmerror.gif

    I did a reboot, but this error still appears in security advisor.

    What to do?

    Russ

    Error reads as follows: "A newer kernel is installed, however the system has not been rebooted. running kernel: 2.6.32-531.1.2.lve1.2.54.el6, most recent installed kernel: 2.6.32-431.11.2.el6

    Reboot the system in the "Graceful Server Reboot" area. Check the boot configuration in grub.conf if the new kernel is not loaded after a reboot."
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please let us know the output from the following command:

    Code:
    uname -a
    Also, could you verify which version of the "Security Advisor" is installed on your system?

    Code:
    grep "return '1." /usr/local/cpanel/Cpanel/Security/Advisor/Assessors/Kernel.pm
    Thank you.
     
  3. russelld

    russelld Member

    Joined:
    Apr 10, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    The output for uname -a was as follows: <server name> 2.6.32-531.1.2.lve1.2.54.el6.i686 #1 SMP Tue Mar 25 07:41:32 EDT 2014 i686 i686 i386 GNU/Linux

    Security Advisor version is '1.01.2';
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you also let us know if this is a VPS (it might be related to an internal case)? Post the output from:

    Code:
    cat /var/cpanel/envtype
    Thank you.
     
  5. russelld

    russelld Member

    Joined:
    Apr 10, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    It is a VPS and this error was not there until I installed CloudLinux.

    Here is what was returned

    standardroot@master [~]#
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please open a support ticket using the link in my signature so we can take a closer look. Your warning message suggests it's related to internal case 97641, but that case is isolated to Virtuozzo VMs, which does not appear to apply to your system. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  7. russelld

    russelld Member

    Joined:
    Apr 10, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
  8. cPanelPeter

    cPanelPeter Technical Analyst III
    Staff Member

    Joined:
    Sep 23, 2013
    Messages:
    569
    Likes Received:
    15
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Michael meant for you to click on the "Submit a ticket here" link in his signature. Just like mine below.
    You may click on either one. Or you can also click Here which will do the same thing.

    Thank you
     
  9. russelld

    russelld Member

    Joined:
    Apr 10, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks for clarifying.

    I have submitted my request.
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to let us know the ticket number so we can update this thread with the outcome.

    Thanks.
     
  11. russelld

    russelld Member

    Joined:
    Apr 10, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Sure. The ticket #4891113
     
  12. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    To update, this issue was addressed by manually forcing an update of the /usr/local/cpanel/Cpanel/Security/Advisor/Assessors/Kernel.pm file.

    Thank you.
     
  13. Yogesh Singh

    Yogesh Singh Member

    Joined:
    Nov 10, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ghaziabad, INDIA
    cPanel Access Level:
    Root Administrator
    Sorry for hijacking this thread. But i think a explanation on what you modified in /usr/local/cpanel/Cpanel/Security/Advisor/Assessors/Kernel.pm file will make more sense :)

    For me its:

    Code:
    SSH direct root logins are permitted.
    Manually edit /etc/ssh/sshd_config and change PermitRootLogin to “no”, then restart SSH in the “Restart SSH” area
    I have edited /etc/ssh/sshd_config and change PermitRootLogin to "no" and restarted SSH. But the warning still shows up.

    Went into /usr/local/cpanel/Cpanel/Security/Advisor/Assessors/SSH.pm and found the below code which is related to my issue.

    Code:
    if ( $sshd_config->{'PermitRootLogin'} =~ m/yes/i || !$sshd_config->{'PermitRootLogin'} ) {
            $self->add_bad_advice(
                'text'       => ['SSH direct root logins are permitted.'],
                'suggestion' => [
                    'Manually edit /etc/ssh/sshd_config and change PermitRootLogin to “no”, then restart SSH in the “[output,url,_1,Restart SSH,_2,_3]” area',
                    $self->base_path('scripts/ressshd'),
                    'target',
                    '_blank'
                ],
            );
        }
        else {
            $self->add_good_advice(
                'text' => ['SSH direct root logins are disabled.'],
            );
    Any suggestion?
     
  14. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Internal case number 110893 is open to address an issue where Security Advisor reports $latest_kernel based on build date rather than the version number. There is currently no specific time frame available on a resolution, but you can monitor changes to "Security Advisor" at:

    https://github.com/CpanelInc/addon_securityadvisor

    In the meantime, you can safely ignore the warning in "Security Advisor" if you have verified the latest kernel is installed and active.

    Thank you.
     
Loading...

Share This Page