The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

latest modsecurity doesn't seem loaded

Discussion in 'Security' started by sehh, May 12, 2008.

  1. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Europe
    I recently recompiled apache/php and kept the base of the previous configuration and added modsecurity. Compilation completed successfully and the new apache and php are running fine.

    Unfortunately, modsecurity is nowhere to be found. There are a bunch of new config files in the httpd/conf directory but the Apache server signature doesn't mention that modsecurity is loaded. I also tried a few common attacks (like proxy redirection) but the modsecurity logs remain empty.

    Server Version: Apache/2.2.8 (Unix) mod_ssl/2.2.8 OpenSSL/0.9.7a mod_bwlimited/1.4

    Any help would be appreciated.
     
  2. Bulent Tekcan

    Bulent Tekcan Well-Known Member

    Joined:
    May 11, 2004
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    Same here...any idea for that ?
     
  3. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Europe
    i believe its because once modsecurity is installed, it has no rules and thus isn't doing anything.

    you need to install some rules from the modsecurity page in WHM.
     
Loading...

Share This Page