Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Latest Source Guardian Loaders

Discussion in 'Security' started by MikeMartinOSM, Mar 20, 2018.

  1. MikeMartinOSM

    MikeMartinOSM Registered

    Joined:
    Apr 8, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    Hello, we recently upgraded our Source Guardian license to the latest version. Issue we are having is cPanel/EasyApache is supplying Source Guardian loader version 11.0.6 (which is from Oct 2016) when our encrypted code requires loader version 11.1.5.

    Is there a way to update the source guardian loader to 11.1.5 within cPanel? If I were to manually update, would cPanel revert the source guardian loader back to 11.0.6 upon restart/upgrade?
     
  2. MikeMartinOSM

    MikeMartinOSM Registered

    Joined:
    Apr 8, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    Server versions are as follows:
    Server OS: CENTOS 7.4 standard
    cPanel/WHM version: v68.0.33
    EasyApache 4
    PHP 5.6
     
  3. JacobPerkins

    JacobPerkins Well-Known Member

    Joined:
    May 2, 2014
    Messages:
    619
    Likes Received:
    96
    Trophy Points:
    103
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hello,

    I have EA-7324 opened to handle this. We'll get these updated ASAP
     
  4. MikeMartinOSM

    MikeMartinOSM Registered

    Joined:
    Apr 8, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    Thanks for looking into things. I assume that is a ticket or something?

    If something gets "updated", does that mean I'd have to wait for a cPanel version update?
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,794
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    This would be an EasyApache 4 update as opposed to a cPanel update. To update EasyApache 4, you can perform either of the following actions:

    1. Click Run System Update in WHM's EasyApache 4 interface (WHM >> Home >> Software >> EasyApache 4).
    2. Run the yum update command.

    I'll monitor the internal case and update this thread once it's published.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Loqman

    Loqman Registered

    Joined:
    Mar 25, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Paris
    cPanel Access Level:
    Reseller Owner
    Hello,

    Using system update as you mentioned before, doesn't update sourceguardian as the latest version available in the cPanel repos is 11.0.6 :

    # yum info ea-php56-php-sourceguardian

    Loaded plugins: fastestmirror, universal-hooks
    Loading mirror speeds from cached hostfile
    * EA4: 185.69.232.245
    * cpanel-addons-production-feed: 185.69.232.245
    * base: mirrors.coreix.net
    * extras: mirrors.coreix.net
    * updates: mirrors.coreix.net
    Installed Packages
    Name : ea-php56-php-sourceguardian
    Arch : x86_64
    Version : 11.0.6
    Release : 2.2.79.cpanel
    Size : 190 k
    Repo : installed
    From repo : EA4
    Summary : Loader for SourceGuardian-encoded PHP files
    URL : http://www.sourceguardian.com/loaders.php
    License : Redistributable
    Description : The SourceGuardian Loader enables use of SourceGuardian-encoded PHP
    : files running under PHP 5.6.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,794
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @Loqman,

    The newer SourceGuardian version is not yet available with EasyApache 4. My response was an answer to the previous poster asking about how to update to the latest Sourceguardian version once internal case EA-7324 is published.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Loqman

    Loqman Registered

    Joined:
    Mar 25, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Paris
    cPanel Access Level:
    Reseller Owner
    Hello Michael,

    Thanks for your answer, yes we actually just wanted to know when it will be available (even approximatively) , to inform our customers.
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,794
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    A time frame isn't available at this time, but I'll update this thread as soon as more information is available. You can also monitor the EasyApache 4 Change Log at:

    EasyApache 4 Change Log 2018 - EasyApache 4 - cPanel Documentation

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,794
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The updated SourceGuardian loaders are included with today's EasyApache 4 maintenance release:

    EA-7324 - Upgrade SourceGuardian loaders to the latest available ( v11.2 for ea-php54~ea-php72): Update to v11.2, drop v11.0.6 (Add 7.1 and 7.2 support)

    The full EasyApache 4 change log should be updated later today:

    EasyApache 4 Change Log 2018 - EasyApache 4 - cPanel Documentation

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice