The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Latest stable screws up PHP on RH6.2??

Discussion in 'General Discussion' started by masood, Oct 18, 2002.

  1. masood

    masood Well-Known Member

    Joined:
    Jun 14, 2002
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    I have already opened a support ticket with cpanel, this is for the cpanel community to help me out:

    WHM 5.0.0
    Cpanel 5.2.0-S17
    RedHat 6.2

    As you probably know the latest upcp brought MySQL binaries into our servers. And here's what I'm getting now from apache:

    [quote:b9bb40edf9]
    Syntax error on line 227 of /usr/local/apache/conf
    /httpd.conf:

    Cannot load /usr/local/apache/libexec/libphp4.so into server
    : /lib/libc.so.6: version `GLIBC_2.2' not found (r
    equired by /usr/lib/libmysqlclient.so.10)

    /etc/httpd/bin/apachectl startssl: httpd could not be started
    [/quote:b9bb40edf9]

    EDIT: Ok, its being worked out now. :)

    EDIT 2: Thanks Nick for speedy fix :p
     
  2. Drake

    Drake Well-Known Member

    Joined:
    Nov 9, 2001
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Attn Nick

    Similar problem here, but I assume same cause.

    /lib/libc.so.6: version `GLIBC_2.2' not found
    (required by /usr/lib/libmysqlclient.so.10)

    our only difference on 3 servers is that &mod_auth_mysql.so& will not dynamically load into apache.

    Yes, of course apache crashed, and customers started calling and were mad.

    Temporarily # remmed out that module from trying to load, but
    need to do a permanent fix, so it will load.

    Masood, will you please post hee what was done to fix it.

    Or NICK, please post here what you needed to do, because that update now makes problems on 3 boxes of ours.

    Thanks,
    DrakeP@compunite.com
     
  3. masood

    masood Well-Known Member

    Joined:
    Jun 14, 2002
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Please try this:

    /scripts/updatenow

    /scripts/sysup

    If this does not help, open a support ticket with cpanel.
     
  4. Drake

    Drake Well-Known Member

    Joined:
    Nov 9, 2001
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Hey, thanks for the reply.

    U know,.. we tried th scripts earlier today, but to no avail.

    After manually downloaded and rebuilt mysql by src. rpm and got it working on one box, then I read your reply and we said, what the heck, try scripts again. I am mystified, now they worked, later in the day.

    But thanks, saved alot of time on fixing the remaining 2 boxes.
     
  5. masood

    masood Well-Known Member

    Joined:
    Jun 14, 2002
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    They worked now because Nick updated them after my ticket ;)
     
Loading...

Share This Page