The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Latest update broke FormMail?

Discussion in 'E-mail Discussions' started by MattGetWeb, Sep 21, 2005.

  1. MattGetWeb

    MattGetWeb Well-Known Member

    Joined:
    Aug 4, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Hi all. It seems the cpanel updates a couple of nights ago broke the /usr/local/cpanel/cgi-sys/FormMail.cgi script. I (and my customers) get 500 Internal Server errors now. As this is a binary, does anyone know how I can fix this?
     
  2. MattGetWeb

    MattGetWeb Well-Known Member

    Joined:
    Aug 4, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    It seems to be related to suEXEC. If I disable the User and Group in the VirtualHost, it works.
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Make sure that that directory and the scripts within are all chmod 755 and owned by root:wheel.
     
  4. MattGetWeb

    MattGetWeb Well-Known Member

    Joined:
    Aug 4, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    You, Sir, are a gentleman and a scholar. That was the solution. It seems all the contents of /usr/local/cpanel/cgi-sys had been changed to root group. Changed them to wheel and all was well. Thanks! --Matt ;^]
     
Loading...

Share This Page