The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Latest VIsitors not working for a single user

Discussion in 'General Discussion' started by Computer_Wizard, Oct 26, 2011.

  1. Computer_Wizard

    Joined:
    Oct 26, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Ok, so i've been trying to figure this out, and have been having no luck. One user on our system has been complaining that their latest users section is not working. It works for me, my co-worker, and any other account i test on. However when i test on hers i get a blank page.

    If i look at the html I find a div with style="display:none" with the id of cpanel_internal_error_1 which contains the following
    Code:
    "Syck parser (line 1, column 158): syntax error at /usr/local/cpanel/Cpanel/Template/Plugin/JSON.pm line 26.	Cpanel::Template::Plugin::JSON::parse('Cpanel::Template::Plugin::JSON=HASH(0xb118940)', '{"column_widths":{"ip":71,"url":138,"localtime":61,"size":37,"re...') called at /usr/local/cpanel/base/frontend/x3/stats/latest_visitors_entries.tmpl line 1
    	eval {...} called at /usr/local/cpanel/base/frontend/x3/stats/latest_visitors_entries.tmpl line 1
    	eval {...} called at /usr/local/cpanel/base/frontend/x3/stats/latest_visitors_entries.tmpl line 7
    	Template::Document::__ANON__('Template::Context=HASH(0xa332b38)') called at /usr/local/cpanel/perl/Template/Document.pm line 151
    	eval {...} called at /usr/local/cpanel/perl/Template/Document.pm line 149
    	Template::Document::process('Template::Document=HASH(0xb12fbe0)', 'Template::Context=HASH(0xa332b38)') called at /usr/local/cpanel/perl/Template/Context.pm line 347
    	eval {...} called at /usr/local/cpanel/perl/Template/Context.pm line 321
    	Template::Context::process('Template::Context=HASH(0xa332b38)', 'Template::Document=HASH(0xb12fbe0)') called at /usr/local/cpanel/perl/Template/Service.pm line 94
    	eval {...} called a"
    and no that was not a copy paste error, it appears to stop the error message part way.

    If I alter the URL to use legacy it works fine, also looking at her logs on the server everything seems to be ok.

    ANY help would be appreciated as this issue has apparently been going on for a few months
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It's possible the the latest visitors cache is corrupted for this account. Try using the following command to move the existing cache out of the way so it can be regenerated:

    Code:
    # mv /home/username/.cpanel/nvdata/latest_visitors /home/username/.cpanel/nvdata/latest_visitors_old
    Replace "username" with the username of the account.

    Thank you.
     
  3. Computer_Wizard

    Joined:
    Oct 26, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thank you so much! that did the trick! I'm not sure why i didnt try that before, but it appears to be working now
     
Loading...

Share This Page