big_bull

Well-Known Member
Nov 19, 2006
150
0
166
cPanel Access Level
Root Administrator
Hello,

The server was overloaded, checked mysql processes, Is leechprotect is causing load on server, how to interpret following output.

+------+--------------+-----------+--------------+---------+------+-------+------------------+
| Id | User | Host | db | Command | Time | State | Info |
+------+--------------+-----------+--------------+---------+------+-------+------------------+
| 4612 | leechprotect | localhost | leechprotect | Sleep | 724 | | |
| 6503 | eximstats | localhost | eximstats | Sleep | 8 | | |
| 7133 | root | localhost | | Query | 0 | | show processlist |
+------+--------------+-----------+--------------+---------+------+-------+------------------+
 

thewebhosting

Well-Known Member
May 9, 2008
1,199
1
68
You can kill the particular MySQL process by firing the below mentioned command at the command prompt:

mysqladmin kill PID#
 

Olsrey

Member
Jun 1, 2010
6
0
51
You can kill the particular MySQL process by firing the below mentioned command at the command prompt:

mysqladmin kill PID#
Killing the process won't stop it happening again. I'm having a rather simular problem and always seems to be Leechprotect and I am yet to find a way to completely disable the crap.
 

Olsrey

Member
Jun 1, 2010
6
0
51
I'm not sure I understand, who forced you to login to your cPanel account and enable leechprotect? If disabling it in your cPanel is not working as expected, that's a bug to me. Kill the running service, disable and you're done.
I have disabled it in WHM but the process still remains to run and keep an SQL connection open for a long time.
 

Infopro

Well-Known Member
May 20, 2003
17,090
518
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
It's not really a problem or a bug, just software we don't want to use that is forced upon us.
I'm not sure I understand, who forced you to login to your cPanel account and enable leechprotect? If disabling it in your cPanel is not working as expected, that's a bug to me. Kill the running service, disable and you're done.
 

Olsrey

Member
Jun 1, 2010
6
0
51
I'm not sure I understand, who forced you to login to your cPanel account and enable leechprotect? If disabling it in your cPanel is not working as expected, that's a bug to me. Kill the running service, disable and you're done.
I have killed the service but it still remains to restart itself. Disableing only removes the option for users to use it, but it still operates on the server.