Let's Encrypt error. Cannot access /.well-known/

Nov 26, 2017
11
0
1
Finland
cPanel Access Level
Root Administrator
Hi
Everything worked fine since lately. I haven't made any changes to the server that should affect this...
But i have several domains in the server
All domains have Let's Encrypt.

cpanel.* and webmail.* are not working on some domains.

If i go to the log, it says for example (sensured paste:)

3:36:03 AM WARN The domain “webmail...sensured...fi” failed domain control validation: The system queried for a temporary file at “http://webmail...sensured...fi/.well-known/acme-challenge/E6H3Q51...sensured...”, but the web server responded with the following error: 403 (Forbidden). A DNS (Domain Name System) or web server misconfiguration may exist.

The ip points to the correct server

How can i dig in and find the error? I cannot find the file to check for permissions =(

Thanks.
 

sktest123

Well-Known Member
Jan 31, 2017
99
6
8
kochin
cPanel Access Level
Root Administrator
ensure the dns settings for the domain including proxy subdomains (cpanel.domain.com,webmail.domain.com) are right, also trace the htaccess rules, like rename it , or directory permissions, run autossl check via manage autossl
 
Nov 26, 2017
11
0
1
Finland
cPanel Access Level
Root Administrator
Whoa. I thought i said it clearly.

I the sub domains are pointing to the correct ip
and i am having this problem on webmail.* and cpanel.* , not my own personal site.

So the problem is the same as in my original post.

I don't know how to check for the directory permissions for webmail and cpanel www-roots since i don't know where they are located.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

Could you open a support ticket using the link in my signature so we can take a closer look to see why domain validation is failing?

Thank you.