Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Let's Encrypt Service down

Discussion in 'Security' started by Nirjonadda, Jul 10, 2017.

Tags:
  1. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    418
    Likes Received:
    10
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hello,

    Today i am getting lot of email about The service “letsencrypt-cpanel” appears to be down. Please let me know this fix. I have do restart but does not help.


    SS.png
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello Everyone,

    To update, it looks like this issue stems from a recent update to a third-party cPanel plugin for Let's Encrypt developed by FleetSSL. You can verify if this particular third-party plugin is installed by running a command such as this:

    Code:
    rpm -qa|grep letsencrypt
    If this third-party plugin is installed, you will see the following entry as part of the output:

    Code:
    letsencrypt-cpanel-0.9.6-1.x86_64
    A recent change to the plugin was made to shut down the service if the license is expired (leading to the service failure warnings), so if you are running this plugin and want to verify if your license is expired, the plugin includes a script you can run to check it:

    Code:
    le-cp self-test
    If you uninstall the plugin, and still receive service failure notifications, you can manually remove it's Chkservd file from the following locations:

    /etc/chkserv.d/
    /var/run/chkservd/


    Then, remove the entry for it from the "/etc/chkserv.d/chkservd.conf" file.

    You may also want to reach out to the developer with additional questions or concerns through their contact form.

    Thank you.

    Edit: This thread was modified to reflect the updated information about the cause of this error message.
     
    #2 cPanelMichael, Jul 10, 2017
    Last edited: Jul 11, 2017
  3. websnail.net

    websnail.net Active Member

    Joined:
    Mar 24, 2002
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    306
    EDIT: Slow off the mark here but I realise now that the clue was in the last post above...

    Just as a little constructive crit... Can I suggest you respond with specific information about the plugin rather than referring to it as "unofficial third party plugin" as it's all unnecessarily cryptic (cue: irony) and doesn't help ID the specific plugin in this instance... There could be others in future so the "plugin that shall not be named" approach seems a mite daft..



    Hit the same problem and found what was causing the issue...

    There's a third party unofficial plugin from FleetSSL (the name has changed) and that installs the service that is failing. From what I can determine the reason it's now an issue (ie: error city) is that they released an update that "fixed" their trial license which in my case was running pretty much indefinitely.

    I can't be 100% sure but it seems the result was that the service shutdown and instead of a UI friendly notification you just have to figure things out yourself. That may not be an accurate assessment as I've ditched the plugin but hopefully gives some ideas...
     
    #3 websnail.net, Jul 11, 2017
    Last edited: Jul 11, 2017
  4. webhostuk

    webhostuk Well-Known Member

    Joined:
    Sep 11, 2013
    Messages:
    112
    Likes Received:
    11
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    They are still in development and with more funding they will surely have a better UI , I feel but compared to free service they are lot better.
     
  5. websnail.net

    websnail.net Active Member

    Joined:
    Mar 24, 2002
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    306
    Now that I'm looking back at the difference between the official and FleetSSL offering I'm remembering why I opted to try the latter out. There's a dearth or support for end-users cpanel functionality and very little in the way of explanation of what the official plugin offers in WHM beyond some basic install/uninstall info and warnings about AutoSSL.

    Certainly something I'll be coming back to when things are a bit more settled.

    Either way, problem solved for now... hopefully the extra info will help someone else who's wondering why changed and how to fix it...
     
  6. PlatinumServerM

    PlatinumServerM Well-Known Member
    PartnerNOC

    Joined:
    Jul 10, 2005
    Messages:
    400
    Likes Received:
    3
    Trophy Points:
    168
    Location:
    New Jersey, USA
    cPanel Access Level:
    Root Administrator
    We started seeing this on a bunch of servers today, the logs say it is from the 3rd party letsencrypt cpanel plugin, and the underlying error says it won't restart because the license was expired. Most of them just choose to have us uninstall it and use the AutoSSL function with letsencrypt.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I've modified my original response to this thread to help clarify the cause of the issue for anyone facing the same problem.

    Thanks!
     
Loading...

Share This Page