Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Let's Encrypt Service Issues

Discussion in 'Security' started by smurf, May 19, 2017.

Tags:
  1. smurf

    smurf Member

    Joined:
    Jun 4, 2009
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    51
    Quick heads up, Let's Encrypt are currently experiencing a service outage affecting connections to their issuance servers.

    More at: Let's Encrypt Status

    The outage is causing timeouts accessing AutoSSL in WHM. It's also not possible to issue new SSL Let's Encrypt certificates at the moment.

    ^JM
     
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,484
    Likes Received:
    60
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
  3. smurf

    smurf Member

    Joined:
    Jun 4, 2009
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    51
    Hi,

    Just to clarify - the issue is upstream with Let's Encrypt's servers. If you check the status link I posted you'll see Let's Encrypt have suffered a service disruption since around 6:52 AM UTC.

    We typically issue a large number of SSL certificates every day and spotted earlier the certs were not being issued and then timeouts accessing WHM's Manage AutoSSL due to the outage at Let's Encrypt. It's not cPanel's fault - I simply wanted to alert other cPanel users :)

    I'm confident Let's Encrypt will be back online soon.

    About the only improvement cPanel could make would be to add some error handling into the Manage AutoSSL function so when timeouts happen upstream an error is displayed in WHM. Currently it just sits loading for around 3-5 minutes and then eventually loads a pretty much blank screen.

    We had to dig into /usr/local/cpanel/logs/error_log to find an answer as to why!

    Code:
    Failed to load information for the AutoSSL module “LetsEncrypt”: Cpanel::Exception::HTTP::Network/(XID t9523x) The system failed to send an <abbr title="Hypertext Transfer Protocol">HTTP</abbr> “get” request to “https://acme-v01.api.letsencrypt.org/terms” because of an error: Timed out while waiting for socket to become ready for reading
    
    Hope this helps everyone else in the same boat...

    ^JM
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,424
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I encourage you to open a feature request if you'd like to see this functionality added to the product:

    Submit A Feature Request

    Thanks!
     
Loading...

Share This Page