Operating System & Version
centos 7.9
cPanel & WHM Version
v92.0.9

BardiaMGTGC

Member
Mar 1, 2021
7
0
1
iran tehran
cPanel Access Level
Root Administrator
while installing lets encrypt autossl with
/usr/local/cpanel/scripts/install_lets_encrypt_autossl_provider
it completed
then after going into whm a warning said a directory doesnt exist in /root/.cpanel
i created that directory and it appeared in whm
now after selecting it and hitting save
API failure: (XID bnbf4e) In order to activate the “LetsEncrypt” AutoSSL provider, you must accept the current terms of service (https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf) by passing the encoded url as the “x_terms_of_service_accepted” parameter. The AutoSSL provider cannot be activated.
any ideas?
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,357
546
273
cPanel Access Level
Root Administrator
Hey there! I'm not seeing any directories that get set up in /root/.cpanel related to Let's Encrypt when I install that on a test machine.

If you try a reinstall of that plugin and you still see issues, could you open a ticket with us so we can check that on our end?
 

BardiaMGTGC

Member
Mar 1, 2021
7
0
1
iran tehran
cPanel Access Level
Root Administrator
looks like after a reinstall of plugin i didnt get the first error relating to the directory inside .cpanel
but i still get API failure: (XID s67sqz) In order to activate the “LetsEncrypt” AutoSSL provider, you must accept the current terms of service (https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf) by passing the encoded url as the “x_terms_of_service_accepted” parameter. The AutoSSL provider cannot be activated.