SOLVED lfd (csf) emails sent to [email protected] instead of admin mail

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
7,975
640
263
Houston
cPanel Access Level
DataCenter Provider
Hi @Nicola Urbinati


Ultimately this issue is more so a CSF related issue and should be handled at ConfigServer Community Forum - Index page but as you just posted I was going to suggest checking the LF_ALERT_TO section.

Let us know how that works and if you continue to receive emails to the wrong address we'll do our best to assist you though that may be to direct you over to them.


Thanks!
 

Nicola Urbinati

Well-Known Member
Feb 1, 2017
73
10
8
Italy
cPanel Access Level
Root Administrator
Hi @cPanelLauren

I noticed today that also cPanel update mails are not routed to the right mail, so I think there's something else amiss in there.
Is somewhere I can look at to see what's wrong?

--1534022190-eximdsn-1995981032
Content-type: text/plain; charset=us-ascii

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

[email protected]
The mail server could not deliver mail to [email protected]. The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.

--1534022190-eximdsn-1995981032
Content-type: message/delivery-status

Reporting-MTA: dns; srvcp01.urbaman.it

Action: failed
Final-Recipient: rfc822;[email protected]
Status: 5.0.0

--1534022190-eximdsn-1995981032
Content-type: message/rfc822

Return-path: <[email protected]ain.com>
Received: from root by srvcp01.urbaman.it with local (Exim 4.91)
(envelope-from <[email protected]>)
id 1fob8Q-00FEnt-8Q
for [email protected]; Sat, 11 Aug 2018 23:16:30 +0200
From: "(Cron Daemon)" <[email protected]>
To: [email protected]
Subject: Cron <[email protected]> (/usr/local/cpanel/scripts/fix-cpanel-perl; /usr/local/cpanel/scripts/upcp --cron)
Content-Type: text/plain; charset=UTF-8
Auto-Submitted: auto-generated
Precedence: bulk
X-Cron-Env: <XDG_SESSION_ID=19472>
X-Cron-Env: <XDG_RUNTIME_DIR=/run/user/0>
X-Cron-Env: <LANG=en_US.UTF-8>
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/root>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=root>
X-Cron-Env: <USER=root>
Message-Id: <[email protected]>
Date: Sat, 11 Aug 2018 23:09:18 +0200

[2018-08-11 23:09:01 +0200] Checking that the RPM DB is OK...
[2018-08-11 23:09:02 +0200] glibc-2.17-222.el7.cloudlinux.x86_64
[2018-08-11 23:09:02 +0200] OK: RPM DB is responding to queries
[2018-08-11 23:09:02 +0200] Testing if rpm_is_working RPM is installed
[2018-08-11 23:09:02 +0200] package rpm_is_working is not installed
[2018-08-11 23:09:02 +0200] Testing if it's possible to install a simple RPM
[2018-08-11 23:09:03 +0200] Preparing... ########################################
[2018-08-11 23:09:03 +0200] Updating / installing...
..........
..........
 

Nicola Urbinati

Well-Known Member
Feb 1, 2017
73
10
8
Italy
cPanel Access Level
Root Administrator
All three emails are sent to the same right mail, and they worked untill the upgrade.
I try to give the update to all of them to see if the system recognize them, but they've been right all the time.

Let's see in a few days if this changes things.
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
7,975
640
263
Houston
cPanel Access Level
DataCenter Provider
Double checking that they're still present in System Mail Preferences wouldn't hurt either. Since you updated them let us know if the issue persists. If it does persist will you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
7,975
640
263
Houston
cPanel Access Level
DataCenter Provider
Hi @Nicola Urbinati


Thank you for the update. I took a look at the ticket and it appears the analyst discovered that the domain in question did not have an entry in /etc/localdomains. All local domains should be in either /etc/localdomains or /etc/remotedomains depending on where they receive their mail.

Can you confirm that the email is going to the correct place now?

Thanks!