Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

lfd on server.xxx.com: Excessive resource usage error problem

Discussion in 'General Discussion' started by Chriz1977, Mar 19, 2011.

  1. Chriz1977

    Chriz1977 Well-Known Member

    Joined:
    Sep 18, 2006
    Messages:
    191
    Likes Received:
    0
    Trophy Points:
    166
    Hi

    Im getting a lot of excessive resource useage errors that look like this :

    Time: Sat Mar 19 12:39:18 2011 +0000
    Account: xxxxxx
    Resource: Process Time
    Exceeded: 1831 > 1800 (seconds)
    Executable: /usr/bin/perl
    Command Line: cpanellogd - http logs for xxxxxx
    PID: 5202
    Killed: No

    Also a lot relating to stats programs (awstats, webailizer, etc). Does anyone know why?

    Any help would be great.

    Cheers

    Chriz
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,309
    Likes Received:
    393
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Chriz1977

    Chriz1977 Well-Known Member

    Joined:
    Sep 18, 2006
    Messages:
    191
    Likes Received:
    0
    Trophy Points:
    166
    Hi

    Yes but my question is is it something to worry about? It looks like the stats programs and the http logs are causing a high load. Could this be due to their size?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,309
    Likes Received:
    393
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    They are going over the default setting of 1800 (seconds) as set in CSF. Note the full line:
    Exceeded: 1831 > 1800 (seconds)

    Perl went over by 31 secs and got flagged for it. Not high load, excessive resource. It used 31 secs more than the setting says it could. You could change that setting, or add this for example to the csf.pignore file:

    exe:/usr/bin/perl

    And this for webalizer stats if needed:

    exe:/usr/local/cpanel/3rdparty/bin/english/webalizer


    Only the Server Administrator would know that, but for example, if this was a freshly installed server thats locked down properly, no it shouldn't be something to worry about. You just need to adjust settings for your own setup.

    Be very careful in what you add to the csf.pignore file, you want to be alerted to many things. Have a look at that file from the CSF UI in WHM for more examples etc.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice