fdnven

Well-Known Member
Feb 14, 2006
120
1
168
Hi,

When any commands are given via root this error is thrown up many times:

"ERROR: ld.so: object '/lib/libsafe.so.1.3' from LD_PRELOAD cannot be preload: ignored."

I can see that libsafe.so.1.3 does indeed exist. I am unable to find any information about the LD_PRELOAD folder.


Thanks
Frank
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello Frank,

You might try editing the file /etc/ld.so.preload and commenting out the /lib/libsafe.so.1.3 line in it as suggested in this online guide:

Code:
http://jkltechinc.blogspot.com/2011/02/fixing-etcldsopreload-cannot-be.html
Please note that /etc/ld.so.preload is not part of a stock installation of cPanel, so this would be something we wouldn't have added to the machine.