beninfl

Member
May 23, 2014
5
0
1
cPanel Access Level
Root Administrator
Howdy! I'm installing this "media node" software on my server, and am having a hell of a time figuring out what to do. The script is for CentOS, and they want $1500 for installation help if their script gives problems (!!).

The instructions provided are to download the script named redhat.sh and then "sudh ./redhat.sh". It seems to puke as a result of doing the yum install git needing dependency "libcurl.so.3". I have libcurl.so.4 on the server, and tried making a symbolic link to libcurl.so.3 by linking to libcurl.so.4 and that didnt work either.

Any ideas? I'm completely stumped and google exhausted. :)

Code:
sudo bash redhat.sh
 Removing Unwanted Softwares... 
Loaded plugins: fastestmirror, presto, security
Setting up Remove Process
No Match for argument: ffmpeg
Loading mirror speeds from cached hostfile
 * base: centos.mirror.freedomvoice.com
 * extras: mirrors.usc.edu
 * rpmforge: mirror.hmc.edu
 * updates: centos.mirror.ndchost.com
Package(s) ffmpeg available, but not installed.
No Match for argument: x264
Package(s) x264 available, but not installed.
No Match for argument: x264-devel
Package(s) x264-devel available, but not installed.
No Match for argument: yasm
Package(s) yasm available, but not installed.
No Packages marked for removal
  Installing Packages... 
Loaded plugins: fastestmirror, presto, security
Loading mirror speeds from cached hostfile
 * base: centos.mirror.freedomvoice.com
 * extras: mirrors.usc.edu
 * rpmforge: mirror.hmc.edu
linuxtech                                                                                                                                                                                                            | 2.6 kB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package git.i386 0:1.7.12.4-1.el5.rf will be installed
--> Processing Dependency: perl-Git = 1.7.12.4-1.el5.rf for package: git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: libcurl.so.3 for package: git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: libssl.so.6 for package: git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: libcrypto.so.6 for package: git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: perl(Git) for package: git-1.7.12.4-1.el5.rf.i386
--> Running transaction check
---> Package git.i386 0:1.7.12.4-1.el5.rf will be installed
--> Processing Dependency: libcurl.so.3 for package: git-1.7.12.4-1.el5.rf.i386
---> Package openssl098e.i686 0:0.9.8e-17.el6.centos.2 will be installed
---> Package perl-Git.i386 0:1.7.12.4-1.el5.rf will be installed
--> Processing Dependency: perl(YAML::Any) for package: perl-Git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: perl(SVN::Core) for package: perl-Git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: perl(SVN::Client) for package: perl-Git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: perl(SVN::Ra) for package: perl-Git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: perl(SVN::Delta) for package: perl-Git-1.7.12.4-1.el5.rf.i386
--> Running transaction check
---> Package git.i386 0:1.7.12.4-1.el5.rf will be installed
--> Processing Dependency: libcurl.so.3 for package: git-1.7.12.4-1.el5.rf.i386
---> Package perl-YAML.noarch 0:0.72-1.el5.rf will be installed
---> Package subversion-perl.i686 0:1.6.11-9.el6_4 will be installed
--> Finished Dependency Resolution
Error: Package: git-1.7.12.4-1.el5.rf.i386 (rpmforge)
           Requires: libcurl.so.3
 You could try using --skip-broken to work around the problem
** Found 8 pre-existing rpmdb problem(s), 'yum check' output follows:
alsa-lib-devel-1.0.22-3.el6.i686 has missing requires of alsa-lib = ('0', '1.0.22', '3.el6')
alsa-lib-devel-1.0.22-3.el6.i686 has missing requires of libasound.so.2
alsa-utils-1.0.22-5.el6.i686 has missing requires of libasound.so.2
alsa-utils-1.0.22-5.el6.i686 has missing requires of libasound.so.2(ALSA_0.9)
alsa-utils-1.0.22-5.el6.i686 has missing requires of libasound.so.2(ALSA_0.9.0rc4)
alsa-utils-1.0.22-5.el6.i686 has missing requires of libasound.so.2(ALSA_0.9.0rc8)
libgcj-4.4.7-4.el6.i686 has missing requires of libasound.so.2
libgcj-4.4.7-4.el6.i686 has missing requires of libasound.so.2(ALSA_0.9)
Loaded plugins: fastestmirror, presto, security
Loading mirror speeds from cached hostfile
 * base: centos.mirror.freedomvoice.com
 * extras: mirrors.usc.edu
 * rpmforge: mirror.hmc.edu
 * updates: centos.mirror.ndchost.com
Setting up Install Process
Package gcc-4.4.7-4.el6.i686 already installed and latest version
Package gcc-c++-4.4.7-4.el6.i686 already installed and latest version
Package 1:make-3.81-20.el6.i686 already installed and latest version
Package 1:pkgconfig-0.23-9.1.el6.i686 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package faac-devel.i386 0:1.26-1.el5.rf will be obsoleted
---> Package git.i386 0:1.7.12.4-1.el5.rf will be installed
--> Processing Dependency: perl-Git = 1.7.12.4-1.el5.rf for package: git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: libcurl.so.3 for package: git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: libssl.so.6 for package: git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: libcrypto.so.6 for package: git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: perl(Git) for package: git-1.7.12.4-1.el5.rf.i386
---> Package libfaac-devel.i686 0:1.28-3.el6 will be obsoleting
--> Processing Dependency: libfaac = 1.28-3.el6 for package: libfaac-devel-1.28-3.el6.i686
---> Package nasm.i686 0:2.07-7.el6 will be installed
---> Package wget.i686 0:1.12-1.8.el6 will be updated
---> Package wget.i686 0:1.12-1.11.el6_5 will be an update
--> Running transaction check
---> Package faac.i386 0:1.26-1.el5.rf will be obsoleted
---> Package git.i386 0:1.7.12.4-1.el5.rf will be installed
--> Processing Dependency: libcurl.so.3 for package: git-1.7.12.4-1.el5.rf.i386
---> Package libfaac.i686 0:1.28-3.el6 will be obsoleting
---> Package openssl098e.i686 0:0.9.8e-18.el6_5.2 will be installed
---> Package perl-Git.i386 0:1.7.12.4-1.el5.rf will be installed
--> Processing Dependency: perl(YAML::Any) for package: perl-Git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: perl(SVN::Core) for package: perl-Git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: perl(SVN::Client) for package: perl-Git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: perl(SVN::Ra) for package: perl-Git-1.7.12.4-1.el5.rf.i386
--> Processing Dependency: perl(SVN::Delta) for package: perl-Git-1.7.12.4-1.el5.rf.i386
--> Running transaction check
---> Package git.i386 0:1.7.12.4-1.el5.rf will be installed
--> Processing Dependency: libcurl.so.3 for package: git-1.7.12.4-1.el5.rf.i386
---> Package perl-YAML.noarch 0:0.72-1.el5.rf will be installed
---> Package subversion-perl.i686 0:1.6.11-10.el6_5 will be installed
--> Processing Dependency: subversion = 1.6.11-10.el6_5 for package: subversion-perl-1.6.11-10.el6_5.i686
--> Running transaction check
---> Package git.i386 0:1.7.12.4-1.el5.rf will be installed
--> Processing Dependency: libcurl.so.3 for package: git-1.7.12.4-1.el5.rf.i386
---> Package subversion.i686 0:1.6.11-9.el6_4 will be updated
---> Package subversion.i686 0:1.6.11-10.el6_5 will be an update
--> Finished Dependency Resolution
Error: Package: git-1.7.12.4-1.el5.rf.i386 (rpmforge)
           Requires: libcurl.so.3
 You could try using --skip-broken to work around the problem
** Found 8 pre-existing rpmdb problem(s), 'yum check' output follows:
alsa-lib-devel-1.0.22-3.el6.i686 has missing requires of alsa-lib = ('0', '1.0.22', '3.el6')
alsa-lib-devel-1.0.22-3.el6.i686 has missing requires of libasound.so.2
alsa-utils-1.0.22-5.el6.i686 has missing requires of libasound.so.2
alsa-utils-1.0.22-5.el6.i686 has missing requires of libasound.so.2(ALSA_0.9)
alsa-utils-1.0.22-5.el6.i686 has missing requires of libasound.so.2(ALSA_0.9.0rc4)
alsa-utils-1.0.22-5.el6.i686 has missing requires of libasound.so.2(ALSA_0.9.0rc8)
libgcj-4.4.7-4.el6.i686 has missing requires of libasound.so.2
libgcj-4.4.7-4.el6.i686 has missing requires of libasound.so.2(ALSA_0.9)
Installation Failed
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Hello :)

It looks like you are using a non-standard YUM repository (rpmforge). Are you using this repo for this particular package? If not, you may want to consider removing it and then running "yum update" again, assuming you are not using that custom repository for other packages.

Thank you.