The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Libraries / Compiling B0rked after CPanel Update

Discussion in 'General Discussion' started by cgray, Apr 21, 2002.

  1. cgray

    cgray Registered

    Joined:
    Aug 15, 2001
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Dear All,

    I have currently CPanel/WHM 4.7.0-stable-76 installed and since it updated to build 76 it appears to have broken all the RedHat 7.2 Libraries. Now I can't compile anything on the box, this symptom has been repeated on other boxen, does anyone have any ideas???

    Cameron
     
  2. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    [quote:a6f3883b85][i:a6f3883b85]Originally posted by cgray[/i:a6f3883b85]
    I have currently CPanel/WHM 4.7.0-stable-76 installed and since it updated to build 76 it appears to have broken all the RedHat 7.2 Libraries. Now I can't compile anything on the box, this symptom has been repeated on other boxen, does anyone have any ideas???
    [/quote:a6f3883b85]

    What are you trying to compile ? Can you please give some more details how you say that the libraries are broken ?

    regards,

    Anand
     
  3. cgray

    cgray Registered

    Joined:
    Aug 15, 2001
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Sorry the FixHeaders Script fixed it....
     
  4. pfmartin

    pfmartin Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    I am running the fixheaders script but it's not doing anything to fix the compile errors that I am getting. When I run the script nothing happens. I checked the RH7.2 update directory and it is empty. This is a redhat 7.2 machine. Any ideas?
     
  5. pfmartin

    pfmartin Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Fixed

    I was able to get compiles to work again by reinstalling the glibc-devel RPM. For some reason it was corrupted I suppose. Anyhow, if you have this problem all I did was force the reinstallation of the RPM.
     
Loading...
Similar Threads - Libraries Compiling B0rked
  1. 3dingbat
    Replies:
    7
    Views:
    1,154
  2. Atrix
    Replies:
    1
    Views:
    274

Share This Page