License issues with hypervisor

Josias

Registered
Jun 29, 2018
2
0
1
Goiania
cPanel Access Level
DataCenter Provider
Hi.
I create a vm in bhyve hypervisor and install CentOS 7.
I transfered all accounts and settings from old server (proxmox).
Now, the cpkeyclt says is a invalid license and i need a full.
But is a VPS, and cpkeyclt is wrong.

dmesg
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Initializing cgroup subsys cpuacct
[ 0.000000] Linux version 3.10.0-862.3.3.el7.x86_64 ([email protected]) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-28) (GCC) ) #1 SMP Fri Jun 15 04:15:27 UTC 2018
[ 0.000000] Command line: BOOT_IMAGE=/vmlinuz-3.10.0-862.3.3.el7.x86_64 root=/dev/mapper/centos-root LANG=en_US.UTF-8 KEYTABLE=us SYSFONT=latarcyrheb-sun16 console=ttyS0
[ 0.000000] e820: BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000009fffe] usable
[ 0.000000] BIOS-e820: [mem 0x0000000000100000-0x000000007fffffff] usable
[ 0.000000] NX (Execute Disable) protection: active
[ 0.000000] SMBIOS 2.6 present.
[ 0.000000] DMI: BHYVE, BIOS 1.00 03/14/2014
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello @Josias,

Bhyve is not a supported virtual environment. You can see a full list of virtual environments that we support at:

Installation Guide - System Requirements - Version 70 Documentation - cPanel Documentation

This question was brought up to our Customer Service team in the past, and it was determined that our licensing system detects the server as a standard/bare metal server when an unsupported virtual environment is utilized. Thus, a VPS license will not work in such an environment. I encourage you to reach out to our Customer Service Department directly via a support ticket, or via email ([email protected]) for further confirmation of this, as they handle all license-related issues.

Thank you.
 

Josias

Registered
Jun 29, 2018
2
0
1
Goiania
cPanel Access Level
DataCenter Provider
I request a update in the license utility, one time i have a vps valid license. I'm runing in a vps and satisfy the requirements. Even lxc is supported, why not bhyve ?. CentOS is 100% compatible, so not make sense cPanel not be. Everything run fine and just the license utility have this error. Is not fair pay more for something equal to others.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello @Josias,

Can you reach out to our Customer Service Department directly? You can submit a ticket to them by clicking here, or send them an email ([email protected]). Our Customer Service Department handles license-related concerns and inquires and will be able to better confirm the license requirements and take your feedback into consideration for potential changes.

Thank you.