cod3gen

Registered
Apr 28, 2012
1
0
51
cPanel Access Level
Root Administrator
Hello all!

Im in the process of installing lighttpd on my server as i need it for streaming possibilities.

I have sucessfully installed lighttpd but having a hard time making it work properly. It loads html files, but no php files. it wont work with fastcgi, wich is installed, but maybe php needs to be rebuiled with it or something?

user and group for lighttpd is nobody..

lighttpd version: 1.4.28
WHM 11.32.2 (build 25)
CENTOS 5.8 x86_64 standard
PHP 5.2.9

Anyone who can help with this?
 
Last edited:

NetMantis

BANNED
Apr 22, 2012
116
1
66
Utah
cPanel Access Level
DataCenter Provider
but maybe php needs to be rebuiled with it or something?
Lighttpd compiles and uses it's own copy of PHP and doesn't use the same PHP install as Apache so to answer your main question, yes you need to setup a different copy of PHP compiled for lighttpd specifically.

Im in the process of installing lighttpd on my server as i need it for streaming possibilities.
That statement seems to be a tiny bit on the backwards side or maybe just a little outdated perhaps.

For streaming and multimedia use, I really haven't seen anything that could keep up with Apache 2.2.x which generally speaking would and has very easily run circles around lighttpd any day of the week, not to mention there is a whole lot more plugin modules and media streaming tools for Apache available than for lighttpd, but if that's what you want to do then fine.

Sounds like you've got the main part of the installation done already.

Recompiling PHP is not all that difficult and it is a straight forward process.

There is a whole bunch of articles and help tutorials on the subject.
Here is just one of many of those -> HOWTO: Configure PHP with lighttpd using fastcgi - VPSLink Wiki