The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

limit email

Discussion in 'E-mail Discussions' started by Cristian99, May 24, 2007.

  1. Cristian99

    Cristian99 Active Member

    Joined:
    Jun 17, 2005
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Hi

    i search solution for spam and lot of email

    1) with :fail: server send email to spammer
    if server receive 1000 email and find :fail: send 1000 reply
    I WOUL DLIKE STOP THIS

    2) is email is SPAM (spamassasin), server reply with email to sender
    I WOULD LIKE STOP THIS

    server don't send email if an email is spam or if a customer have :fail:

    thanks
     
  2. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    Set the account to :blackhole: instead.

    Set a filter to delete message with *SPAM* in the subject instead of delivering.
     
  3. Cristian99

    Cristian99 Active Member

    Joined:
    Jun 17, 2005
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Set the account to :blackhole: instead

    Thanks, but all told that BLACKHOLE is not fine


    Set a filter to delete message with *SPAM* in the subject instead of delivering.
    just do it, but i would like limite reply that server send when an email is SPAM

    Thanks

    now i change fail with blackhole
     
  4. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    Blackhole automatically discards messages to addresses that do not exist. It's a problem because no one will know the message sent did not arrive - it just never arrives. It is good for spam IMO because your mail queue won't fill up with thousands of bounces. As an alternative you could change the freeze time and such on messages and use fail

    Limit the reply when spam? When SA finds a message as Spam it will forward to your account and tell you. If you dont' want that then turn on a filter to discard or put in a spam folder.
     
  5. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    With :fail: your server does not send a failure message.

    To understand this, you need to know how an e-mail transaction works.

    When someone sends a message to you or tries to send an e-mail message to you, the transaction follows:

    In this scenario, Server refers to your server the server hosting your domain. Client refers to any client or other mail server that is connecting to your mail server and trying to send you mail.

    Server: 220 Welcome banner
    Client: EHLO <hostname>
    Server: 250 Response
    Client: mail from: <from@address.com>
    Server: 250 OK
    Client: rcpt to: <to@domain.com>


    At this point if the to@domain.com does not exist on your server, but the domain.com account does, and you have the default box set to :fail:, then the transaction stops with a 550 response code.

    When the client encounters a 550 code, it stops.

    Users who are e-mailing you at a bad address, they may get a bounce message, but this bounce message comes from the sending server, not your server.

    Another words, say a spammer is using mail.isp.com as to send out mail. They fake an address and say that a message is being sent to you@domain.com. They send the spam message from spam@yahoo.com.

    mail.isp.com is going to try and to send a message to you@domain.com. But if you@domain.com does not exist and you have your default box set to :fail: then it is going to run into the above scenario. Once mail.isp.com receives the 550 code because of the :fail:, then mail.isp.com may be configured to send a bounce message to spam@yahoo.com saying that it was unable to send the message to you@domain.com. No where is your server involved in the sending of that message.
     
  6. jrehmer

    jrehmer Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Denver, CO
    Very nicely put! Bottom line, you want :fail:. If you're still having a problem you may need to invest in some third party spam protection such as MX Logic.
     
Loading...

Share This Page