The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

limiting amount of email "nobody" can send..

Discussion in 'E-mail Discussions' started by InternetPEI, Aug 23, 2006.

  1. InternetPEI

    InternetPEI Well-Known Member

    Joined:
    May 26, 2003
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16
    Does the user nobody follow the same rules as other users when you use the max amount of email sending per hour in WHM?

    Thanks
     
  2. konrath

    konrath Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    367
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brasil
    No way... I believe :rolleyes:
     
  3. InternetPEI

    InternetPEI Well-Known Member

    Joined:
    May 26, 2003
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16

    No way you know of - or no way possible? Not sure what the comment meant with the rolleyes?

    Thanks
     
  4. konrath

    konrath Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    367
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brasil
    Hello

    It is impossible...I believe

    In WHM, limit only emails from SMTP but no will limit amount of email "nobody" can send..

    I also look this solution :rolleyes:

    Konrath
     
  5. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,384
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The only way that I know of that this might work (not sure if it does) is to run PHP as CGI (phpsuexec) and disable nobody sending in your WHM.

    Then you can set a low max e-mails per hour in your WHM and then set up larger limits for accounts in the /var/cpanel/maxemails file.

    For example, you might set your max e-mails per hour to 100 messages per hour. But then if a particular client has a mailing list that sends out a message through a PHP script you can increase that limit by adding the appropriate line to the /var/cpanel/maxemails file.

    Again, not sure if this will work or not. I think it should. If somebody has this set up in this way or wants to test it, let us know if this works.
     
  6. konrath

    konrath Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    367
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brasil
    Tweak Settings and /var/cpanel/maxemails no limit amount of email "nobody" can send..
    This functions only for connection pop and smtp


    If you disable nobody sending in your WHM.. then no more email out via nobody..
    You kill any forms.

    Some another suggestion? This problem is serious because it does not have control
     
  7. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,384
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    This is why you run PHP as CGI, likely with phpsuexec. If you are running phpsuexec and have suexec enabled for CGI scripts, then there really shouldn't be any processes running as nobody on the server (atleast not in the sense of any scripts that send out mail).

    This way you can disable nobody sending, since there shouldn't be anything on the server sending mail as nobody anyway.

    You may be right about the maxemails file, I'm not sure if it will apply to scripts or not. I really don't know why it would not, but someone can clue me in as to why it does not, if it does not.
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You should be ably to put the hostname into the maxemails file to effectively limit nobody. The whole thing will be bypassed if you allow scripts to send out email directly from port 25, though.
     
  9. konrath

    konrath Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    367
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brasil
    Hello Chirpy

    Thank you :D and I ask

    Only this?
    Excuse-me, I did not understand.

    Another configuration is necessary or only put hostname in maxemails?

    Thank you
    Konrath
     
  10. InternetPEI

    InternetPEI Well-Known Member

    Joined:
    May 26, 2003
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16
    Thanks :)

    I had the phpsuexec running with CGI, but ever since doing that noticed twice the server load, and other issues I didnt like.

    I am more focused on other ways to do this then the phpsuexec.

    Thanks
     

Share This Page