SOLVED Link to sub domain returns to domain

durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
Hi, i created a dns sub domain and then i opened up a cpanel account for it so that it could have its own ip..

But for some reason when i hit the link on the main domain example.com to go to the store which should be store.example.com it comes right back to example.com

what would cause that, i dont have any redirects. the wordpress address is right in the database so im not sure why its doing this..

I am going through cloudflare for my dns and i do have the sub domain pointed at the new ip.
 
Last edited by a moderator:

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
807
158
168
New Jersey
cPanel Access Level
DataCenter Provider
Works fine for me, you either fixed it or need to clear your browser cache.
 

durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
strange, im still coming back to domain... i ran ccleaner, cleared dns cache, and rebooted pc... ill try restarting the modem and see if that works.

Update - i opened up IE that i never use and you are right it works.... sometimes cache can be such a pain because it gets stuck sometimes...

Ok thanks and moderator thanks for changing the names i hate to put my site names on here but sometimes i do because i have to. Thanks for editing that... :)
 
Last edited:
  • Like
Reactions: cPanelMichael

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
807
158
168
New Jersey
cPanel Access Level
DataCenter Provider
Were you using Chrome? If so, in most cases if you open up the developer console, click the Network tab, and then check the 'disable cache' box that will allow you to test without clearing your browser cache
 
  • Like
Reactions: cPanelMichael

durangod

Well-Known Member
May 12, 2012
504
46
78
cPanel Access Level
Website Owner
oh cool didnt know that, thanks :)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

I've marked this thread as solved. Thanks to everyone that helped!