LiteSpeed is not running. Apache is not running.

charliecres

Active Member
Mar 5, 2020
34
3
8
Dhaka
cPanel Access Level
Root Administrator
Litespeed and apache both are stopped working.

here is the error...

Litespeed..

  • Failed to bring up LiteSpeed
    [*]Apache Stopped.
    [*][OK] lshttpd.service has been successfully installed!
    [*]---
    [*]metadata:
    [*]command: configureservice
    [*]reason: Enabled monitoring for httpd.
    [*]result: 1
    [*]version: 1
    [*]Redirecting to /bin/systemctl start httpd.service
    [*]Job for lshttpd.service failed because the control process exited with error code. See "systemctl status lshttpd.service" and "journalctl -xe" for details.
    [*]LiteSpeed is not up within 30 secs, try again by removing /tmp/lshttpd/.
    [*]Redirecting to /bin/systemctl start httpd.service
    [*]Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
    [*]**ERROR** LiteSpeed is not up within 60 secs, please check the error log and try again.
    [*]Apache port offset has been set to 0.




for Apache...



  • metadata:
  • command: configureservice
  • reason: Enabled monitoring for httpd.
  • result: 1
  • version: 1
  • Waiting for “httpd” to start ………Waiting for httpd,litespeed,lscgid to shutdown ... not running.
  • ……failed.

  • Cpanel::Exception::Services::StartError
  • Service Status
  • undefined status from Cpanel::ServiceManager::Services::Httpd

  • Service Error
  • (XID kv7345) The “httpd” service failed to start.

  • Startup Log


  • and ..

  • Aug 28 08:01:25 server11 systemd: Failed to start Apache web server managed by cPanel EasyApache.
    [*] Aug 28 08:01:25 server11 restartsrv_httpd: [ERROR] Cannot find /usr/local/apache/bin/litespeed
    [*]

    [*]httpd has failed. Contact your system administrator if the service does not automagically recover.
    [*]**ERROR** Apache is not up within 30 secs. Please check the log file.
last..




  • Failed to switch to Apache
    [*]This may be due to a configuration error. To manually check this problem, please ssh to your server.
    [*]Use the following steps to manually switch to Apache:
    [*]Stop LiteSpeed if lshttpd still running: pkill -9 litespeed
    [*]Restore Apache httpd if /usr/sbin/httpd_ls_bak exists: mv -f /usr/sbin/httpd_ls_bak /usr/sbin/httpd
    [*]Run the Apache restart command manually: service httpd restart and check for errors.
 
Last edited by a moderator:

HostNoc

Well-Known Member
Feb 20, 2020
155
38
28
Ontario
cPanel Access Level
Root Administrator
HI


You need to make sure apache is stopped.

killall -9 httpd

then start LSWS,
/usr/local/lsws/bin/lswsctrl start
then check error log.

make sure /tmp partition has enough disk space.