SOLVED [LiteSpeed Notice] LSWS Version 5.3.6 Required For MultiPHP Functionality in cPanel & WHM Version 78

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
Hello Everyone!

A recent LSWS Version 5.3.6 build includes the following change to ensure MultiPHP functionality works in cPanel & WHM version 78:

Fixed AddHandler directive behavior to be the same as AddType.

You can check to see the installed build number with the following command:

Code:
cat /usr/local/lsws/BUILD
You can browse to WHM >> Plugins >> LiteSpeed Web Server Plugin to update your system to the latest LSWS build for version 5.3.6, or run the following command as root:

Code:
/usr/local/lsws/admin/misc/lsup.sh -f -v 5.3.6
LiteSpeed documents the update procedure at:

litespeed_wiki:admin:new-build-notifications [LiteSpeed Wiki]

Thank you.
 
Last edited:

vacancy

Well-Known Member
Sep 20, 2012
309
89
28
cPanel Access Level
Root Administrator
Thanks for information.

Today I've had this problem on a client's server.

When php versions were selected, the inherit php version was running. I found that the litespeed version on this server is 5.3.5, the problem is solved after updating litespeed to 5.3.6.
 
  • Like
Reactions: cPanelMichael

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
Hello Everyone,

To update, we added a new blocker in cPanel & WHM version 78.0.13 to ensure cPanel updates to cPanel & WHM version 78 (from prior versions) fail when the installed LSWS version is older than 5.3.6:

Fixed case CPANEL-25790: Block updates to cPanel & WHM version 78 from LiteSpeed versions which are older than 5.3.6.

Thank you.
 
  • Like
Reactions: vacancy

Karl

Well-Known Member
PartnerNOC
Aug 10, 2001
85
1
308
It isn't just that you need 5.3.6, it's that you need the latest build of it as well. We had a server on 5.3.6 already that was broken this-morning by this until we did a re-install (which will fetch the latest build level).
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
Hi @Karl,

I've updated the first post on this thread to reflect that information, however note we referenced LSWS v5.3.6 because the fix was included in v5.3.5 Build 7. The full change log is available on the LiteSpeed Edge-Users group:

Google Groups - LiteSpeed Edge-Users

Thank you.
 

LucasRolff

Well-Known Member
May 27, 2013
128
74
28
cPanel Access Level
Root Administrator
It isn't just that you need 5.3.6, it's that you need the latest build of it as well. We had a server on 5.3.6 already that was broken this-morning by this until we did a re-install (which will fetch the latest build level).
LiteSpeed Web Server 5.3.6 is based on 5.3.5 build 9, and all 5.3.6 releases do work with AddHandler which is what cPanel uses in v78.

5.3.5 build 7 or newer will work with AddHandler as mentioned by @cPanelMichael - that includes every 5.3.6 build.
 
  • Like
Reactions: cPanelMichael