Litespeed Script Handler Errors after Removing PHP 5.4 and 5.5 in EasyApache4

linux4me2

Well-Known Member
Aug 21, 2015
259
76
28
USA
cPanel Access Level
Root Administrator
I'm running WHM 58 build 13 on a CENTOS 6.8 x86_64 virtuozzo host running Litespeed 5.0.19. I only use PHP 5.6 and 7, so I deselected PHP 5.4 and 5.5 in EA4 and rebuilt the profile, then restarted Litespeed for good measure. I also ran the following command to make sure the PHP 5.4 and 5.5 packages were completely removed:
Code:
yum remove ea-php54* ea-php55*
I didn't see the PHP 5.4 and 5.5 selections in the drop-downs on the MultiPHP pages anymore, but I was seeing the following in the error_log:
2016-08-09 06:29:10.130 [ERROR] [config:server:epsr:lsphp54] invalid path - /opt/cpanel/ea-php54/root/usr/bin/lsphp, it cannot be started by Web server!
2016-08-09 06:29:10.130 [ERROR] [config:server:epsr:lsphp55] invalid path - /opt/cpanel/ea-php55/root/usr/bin/lsphp, it cannot be started by Web server!
2016-08-09 06:29:10.140 [ERROR] [config:scripthandler] Can not find handler with type: 13, name: lsphp54.
2016-08-09 06:29:10.140 [ERROR] [config:scripthandler] Can not find External Application: lsphp54, type: lsapi
2016-08-09 06:29:10.140 [ERROR] [config:scripthandler] use static file handler for suffix [php54]
2016-08-09 06:29:10.140 [ERROR] [config:scripthandler] Can not find handler with type: 13, name: lsphp55.
2016-08-09 06:29:10.140 [ERROR] [config:scripthandler] Can not find External Application: lsphp55, type: lsapi
2016-08-09 06:29:10.140 [ERROR] [config:scripthandler] use static file handler for suffix [php55]
On Litespeed's site, I found a description of the steps involved in manually upgrading EA3 to EA4, and it looks like part of the problem was that I still had the script handlers for PHP 5.4 and 5.5 installed in Litespeed Configuration -> Server -> Script Handler. I deleted both of them, and restarted Litespeed. Now the errors I get are:
2016-08-09 12:00:44.014 [ERROR] [config:server:epsr:lsphp54] invalid path - /opt/cpanel/ea-php54/root/usr/bin/lsphp, it cannot be started by Web server!
2016-08-09 12:00:44.014 [ERROR] [config:server:epsr:lsphp55] invalid path - /opt/cpanel/ea-php55/root/usr/bin/lsphp, it cannot be started by Web server!
Is there somewhere else I need to remove the references to PHP 5.4 and 5.5 in order to prevent these errors?
 

vacancy

Well-Known Member
Sep 20, 2012
395
117
93
Turkey
cPanel Access Level
Root Administrator
After you remove the yum package, you need to delete the admin panel LiteSpeed php54 and php55 line from the external app and script handler of the script, after LiteSpeed restart.
 

linux4me2

Well-Known Member
Aug 21, 2015
259
76
28
USA
cPanel Access Level
Root Administrator
Thanks vacancy! That was it. I had removed them from the Script Handler tab, but not the External App tab. I removed PHP 5.4 and 5.5 from the External App tab, restarted Litespeed, and no more errors.